summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Jain2019-06-01 03:05:12 +0530
committerAyush Jain2019-06-01 03:05:12 +0530
commitdc5053300d6eeb165588855379ed0f3fd004f4fb (patch)
treead774031584c60ff6d8d9308b60d326b91915a93
downloadaur-dc5053300d6eeb165588855379ed0f3fd004f4fb.tar.gz
Release v2.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..968bfec09b69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dunner
+ pkgdesc = A container based task-runner
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://github.com/leopardslab/dunner
+ arch = any
+ license = MIT
+ makedepends = go
+ makedepends = dep
+ makedepends = git
+ depends = docker
+ source = dunner-2.1.1.tar.gz::https://github.com/leopardslab/dunner/archive/v2.1.1.tar.gz
+ sha256sums = 970087b3fd9f2d7a99c37e72bc1639a93f976847cbecb79b7b6f2312658f6818
+
+pkgname = dunner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edcfe1110594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Milindu Sanoj Kumarage <AgentMilindu@gmail.com>
+# Maintainer: Ayush Jain <ayushjain20n@gmail.com>
+# Maintainer: Apoorva M <app.apoorva@gmail.com>
+pkgname=dunner
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='A container based task-runner'
+arch=('any')
+url='https://github.com/leopardslab/dunner'
+license=('MIT')
+makedepends=('go' 'dep' 'git')
+depends=('docker')
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v${pkgver}.tar.gz")
+sha256sums=('970087b3fd9f2d7a99c37e72bc1639a93f976847cbecb79b7b6f2312658f6818')
+
+prepare(){
+ if [ -z "$GOPATH" ]
+ then
+ echo "\$GOPATH is empty, setting it to ~/go"
+ mkdir -p $HOME/go
+ export GOPATH=$HOME/go
+ mkdir -p $GOPATH/bin
+ mkdir -p $GOPATH/src
+ mkdir -p $GOPATH/pkg
+ else
+ echo ""
+ fi
+ mkdir -p $GOPATH/src/github.com/leopardslab/$pkgname
+ mv $pkgname-$pkgver/* $GOPATH/src/github.com/leopardslab/$pkgname
+ cd $GOPATH/src/github.com/leopardslab/$pkgname
+ echo "Installing dependencies"
+ dep ensure -v
+}
+
+build() {
+ cd $GOPATH/src/github.com/leopardslab/$pkgname
+ echo "Installing dunner"
+ go install \
+ -gcflags "all=-trimpath=$GOPATH" \
+ -asmflags "all=-trimpath=$GOPATH" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v ./...
+}
+
+#check() {
+# cd $GOPATH/src/github.com/leopardslab/$pkgname
+# go test ./...
+#}
+
+package() {
+ install -Dm755 $GOPATH/bin/$pkgname /usr/bin/$pkgname
+}