summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2018-01-07 13:58:44 +0100
committerMorten Linderud2018-01-07 13:58:44 +0100
commit14c816e2b6b04c4cd86a3fe7899d07f99c03d471 (patch)
treeda7baf17c2c7d82e630b0ca9c1f99de36bea50d4
parent88fdc6b9c742fff0e2bd7e52fec07efa62ba39f0 (diff)
downloadaur-14c816e2b6b04c4cd86a3fe7899d07f99c03d471.tar.gz
upgpkg: dunst-git 1.2.0.r221.g18df78c-1
upstream release Updated dunst-git Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD48
2 files changed, 19 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9da58b1154e..8c603c29c149 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 20 06:16:10 UTC 2017
+# Sun Jan 7 12:58:45 UTC 2018
pkgbase = dunst-git
- pkgdesc = a lightweight notification-daemon - git version
- pkgver = r1048.5a9f37b
+ pkgdesc = Lightweight and customizable notification daemon
+ pkgver = 1.2.0.r221.g18df78c
pkgrel = 1
url = https://dunst-project.org/
arch = i686
@@ -15,14 +15,14 @@ pkgbase = dunst-git
depends = libxss
depends = pango
depends = libnotify
- depends = gtk3
+ depends = gdk-pixbuf2
depends = libxdg-basedir
+ depends = libxrandr
provides = dunst
provides = notification-daemon
provides = dunstify
conflicts = dunst
conflicts = dunstify
- options = !makeflags
source = git+https://github.com/dunst-project/dunst
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4a05f9b31f46..c001e9ced920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,37 @@
+# Maintainer: Morten Linderud <foxboron@archlinux.org>
+# Contributor: Moritz Maxeiner <moritz@ucworks.org>
+# Contributor: Stefan-Husmann@t-online.de
# Contributor: Army
-# Maintainer: Moritz Maxeiner <moritz@ucworks.org>
-# Co-Maintainer: Stefan-Husmann@t-online.de
pkgname=dunst-git
-_gitname=dunst
-pkgver=r1048.5a9f37b
+_pkgname=dunst
+pkgver=1.2.0.r221.g18df78c
pkgrel=1
-pkgdesc="a lightweight notification-daemon - git version"
+pkgdesc="Lightweight and customizable notification daemon"
arch=('i686' 'x86_64' 'armv7h')
url="https://dunst-project.org/"
license=('BSD')
-depends=('libxinerama' 'libxss' 'pango' 'libnotify' 'gtk3')
-if [ ! -e ${SRCDEST}/config.h ]; then
- depends+=('libxdg-basedir')
-fi
+depends=('libxinerama' 'libxss' 'pango' 'libnotify' 'gdk-pixbuf2' 'libxdg-basedir' 'libxrandr')
makedepends=('git' 'perl')
provides=('dunst' 'notification-daemon' 'dunstify')
conflicts=('dunst' 'dunstify')
source=('git+https://github.com/dunst-project/dunst')
md5sums=('SKIP')
-options=('!makeflags')
pkgver() {
- cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- cd ${_gitname}
- if [ -e ${srcdir}/config.h ]; then
- msg "Using custom config.h"
- cp ${srcdir}/config.h .
- fi
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${_gitname}
- if [ -e ${SRCDEST}/config.h ]; then
- CFLAGS=-DSTATIC_CONFIG make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
- CFLAGS=-DSTATIC_CONFIG make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
- else
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
- fi
+ cd "${_pkgname}"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
}
package() {
- cd ${srcdir}/${_gitname}
- if [ -e ${SRCDEST}/config.h ]; then
- CFLAGS=-DSTATIC_CONFIG make DESTDIR="${pkgdir}" PREFIX=/usr install
- else
- make DESTDIR="${pkgdir}" PREFIX=/usr install
- fi
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
install -Dm755 dunstify "${pkgdir}"/usr/bin/dunstify
install -Dm755 contrib/dunst_espeak.sh "${pkgdir}"/usr/bin/dunst_espeak.sh
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE