summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Crichton2015-12-14 09:21:47 -0500
committerMark Crichton2015-12-14 09:21:47 -0500
commitc2c13aec6460f2f0b37ca0d2f8dd3e47c5d8ad5b (patch)
treed29adb999c1c1bc8e18562dbd9d6ae73ffe5ce73
downloadaur-c2c13aec6460f2f0b37ca0d2f8dd3e47c5d8ad5b.tar.gz
Update to 1.9.17
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD43
-rwxr-xr-xduo_unix.install12
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c57980aeba4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 14:15:12 UTC 2015
+pkgbase = duo_unix
+ pkgdesc = Login utility and PAM module for Duo Security two-factor authentication
+ pkgver = 1.9.17
+ pkgrel = 1
+ url = https://www.duosecurity.com/docs/duounix
+ install = duo_unix.install
+ arch = i686
+ arch = x86_64
+ license = custom:GPL2
+ depends = openssl
+ depends = pam
+ backup = etc/duo/login_duo.conf
+ backup = etc/duo/pam_duo.conf
+ source = https://dl.duosecurity.com/duo_unix-1.9.17.tar.gz
+ sha1sums = 6aba1fd91cef87ddf97a5f0b6cc5fddc2db35a5b
+
+pkgname = duo_unix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2b552e427689
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mark Crichton <crichton at gmail dot com>
+# Contributor: Josh <moc tod liamg ta suoecal>
+
+pkgname=duo_unix
+pkgver=1.9.17
+pkgrel=1
+pkgdesc='Login utility and PAM module for Duo Security two-factor authentication'
+arch=('i686' 'x86_64')
+url='https://www.duosecurity.com/docs/duounix'
+license=('custom:GPL2')
+depends=('openssl' 'pam')
+install="${pkgname}.install"
+backup=('etc/duo/login_duo.conf' 'etc/duo/pam_duo.conf')
+source=("https://dl.duosecurity.com/duo_unix-${pkgver}.tar.gz")
+
+# https://www.duosecurity.com/docs/checksums#duounix
+sha1sums=('6aba1fd91cef87ddf97a5f0b6cc5fddc2db35a5b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # By default, login_duo is installed setuid root with system-wide config files
+ # Using nobody as the privsep user to match the default openssh package
+ # More config options here: https://github.com/duosecurity/duo_unix
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --with-pam=/usr/lib/security \
+ --with-privsep-user=nobody
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+
+ # The license is GPL, but with a couple clarifications/exceptions (link the LICENSE file to /usr/share/licenses)
+ # This link won't point to anything if the !docs option is specified
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/share/doc/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/duo_unix.install b/duo_unix.install
new file mode 100755
index 000000000000..993e80eb149d
--- /dev/null
+++ b/duo_unix.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo '==> You need to make some configuration changes to use duo_unix'
+ echo '==> Instructions can be found here: https://www.duosecurity.com/docs/duounix'
+ echo '==> Make sure to use /usr/bin/login_duo rather than /usr/sbin/login_duo'
+}
+
+post_upgrade() {
+ if [[ $(vercmp $2 1.9-3) -lt 0 ]]; then
+ echo '==> login_duo has moved to /usr/bin alongside all binaries'
+ echo '==> Please update this path in your scripts or configs if applicable'
+ fi
+}