summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErsei2022-04-07 17:35:36 -0400
committerErsei2022-04-07 17:35:36 -0400
commit238a0ff0eee69b0a0aeb56d3b7d55aa3cc57c644 (patch)
treefa774187333b89af69f075df8dec7d03a6e76d31
downloadaur-238a0ff0eee69b0a0aeb56d3b7d55aa3cc57c644.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a557be70bc1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = duolibre
+ pkgdesc = Authenticate to Duo 2FA systems without the Duo Mobile app
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/evan-goode/duolibre
+ arch = any
+ license = Unlicense
+ makedepends = python-setuptools
+ depends = python-pycryptodome
+ depends = python-click
+ depends = python-pyotp
+ depends = python-qrcode
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/14/2d/4ef947e8d74053e6dec890d7558ed86f55625a8c341969ef5bc1dc3713e6/duolibre-1.0.1.tar.gz
+ sha256sums = aa52f287a697af3143242078264620e7ce1bc0e6df4ea3a5701b28baef2d44ff
+
+pkgname = duolibre
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28d80646cbbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ersei <samb at disroot dot org>
+
+pkgname=duolibre
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Authenticate to Duo 2FA systems without the Duo Mobile app"
+arch=('any')
+url="https://github.com/evan-goode/duolibre"
+license=('Unlicense')
+depends=('python-pycryptodome' 'python-click' 'python-pyotp' 'python-qrcode'
+ 'python-requests')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/14/2d/4ef947e8d74053e6dec890d7558ed86f55625a8c341969ef5bc1dc3713e6/duolibre-1.0.1.tar.gz")
+sha256sums=('aa52f287a697af3143242078264620e7ce1bc0e6df4ea3a5701b28baef2d44ff')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" -O1 --skip-build
+}