summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Waller2016-06-01 20:48:08 -0700
committerEric Waller2016-06-01 20:48:08 -0700
commitce90197c084abda5c5ffb3af80d5fd8866053c7c (patch)
tree8723c8cd493ffeb045c2780f6b110dac694168d9
downloadaur-ce90197c084abda5c5ffb3af80d5fd8866053c7c.tar.gz
Initial Release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c78a961bc0b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dup.py
+ pkgdesc = Duplicate File manager with multimedia geolocation metadata extensions
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ewwaller/dup.py
+ arch = any
+ license = GPL3
+ depends = python
+ depends = sqlite
+ optdepends = argparser
+ optdepends = python-gobject
+ optdepends = libgexiv2
+ source = git+https://github.com/ewwaller/dup.py.git
+ md5sums = SKIP
+
+pkgname = dup.py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..898c2f6d42d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Eric Waller <ewwaller@gmail.com>
+
+pkgname=dup.py
+pkgver=1.0
+pkgrel=1
+pkgdesc='Duplicate File manager with multimedia geolocation metadata extensions'
+arch=('any')
+url='https://github.com/ewwaller/dup.py'
+license=('GPL3')
+depends=('python' 'sqlite')
+optdepends=('argparser' 'python-gobject' 'libgexiv2')
+source=("git+https://github.com/ewwaller/dup.py.git")
+md5sums=('SKIP')
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 dup.1.gz ${pkgdir}/usr/share/man/man1/${pkgname}.1.gz
+}