summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Kocis2020-06-13 02:59:09 -0700
committerAdrian Kocis2020-06-13 03:31:29 -0700
commit1b0ea8f5a1191f0dda2fadcfd953155972f4d522 (patch)
treef5bd6f13fbd16b752d6285e86ceecf6b7c121827
parent93f686d4eccba939a78cac6973db5522c44551f3 (diff)
downloadaur-dupd-git.tar.gz
Fix PKGBUILD (remove unnecessary libraries/patches)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
-rw-r--r--test.patch27
3 files changed, 11 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bddcb2d79199..1b6d9d719348 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = dupd-git
pkgdesc = CLI utility to find duplicate files
- pkgver = 1.3.r83.ged1888f
+ pkgver = 1.7.r43.gf137a38
pkgrel = 1
url = http://www.virkki.com/dupd
arch = i686
arch = x86_64
- arch = any
license = GPL3
makedepends = git
- provides = dupd=1.3.r83.ged1888f
+ depends = openssl
+ depends = sqlite
+ provides = dupd=1.7.r43.gf137a38
conflicts = dupd
source = dupd::git+https://github.com/jvirkki/dupd.git
- source = libbloom::git+https://github.com/jvirkki/libbloom.git
- source = test.patch
md5sums = SKIP
- md5sums = SKIP
- md5sums = 5228e790f359376d51a9348cb72092eb
pkgname = dupd-git
diff --git a/PKGBUILD b/PKGBUILD
index 8dc4121f901c..2e6f466e48af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: James An <james@jamesan.ca>
+# Maintainer: Adrian Kocis <adrian dot kocis at gmail>
+# Maintainer: James An <james at jamesan dot ca>
pkgname=dupd-git
_pkgname=${pkgname%-git}
-pkgver=1.3.r83.ged1888f
+pkgver=1.7.r43.gf137a38
pkgrel=1
pkgdesc="CLI utility to find duplicate files"
-arch=('i686' 'x86_64' 'any')
+arch=('i686' 'x86_64')
url="http://www.virkki.com/$_pkgname"
license=('GPL3')
+depends=( 'openssl' 'sqlite')
makedepends=('git')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("$_pkgname"::"git+https://github.com/jvirkki/$_pkgname.git"
- "libbloom"::"git+https://github.com/jvirkki/libbloom.git"
- test.patch)
-md5sums=('SKIP'
- 'SKIP'
- '5228e790f359376d51a9348cb72092eb')
+source=("$_pkgname"::"git+https://github.com/jvirkki/$_pkgname.git")
+md5sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -27,28 +25,17 @@ pkgver() {
)
}
-prepare() {
- cd "$_pkgname"
-
- patch -p1 -i ../test.patch
-}
-
build() {
- cd libbloom && make && cd ..
cd "$_pkgname"
-
make
}
check() {
cd "$_pkgname"
- mv tests/{,~}test.72
-
make test
}
package() {
cd "$_pkgname"
-
install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}
diff --git a/test.patch b/test.patch
deleted file mode 100644
index 9fa947a9954d..000000000000
--- a/test.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/tests/output.72~ b/tests/output.72~
-new file mode 100644
-index 0000000..995afc7
---- /dev/null
-+++ b/tests/output.72~
-@@ -0,0 +1,8 @@
-+
-+
-+
-+ 1
-+ 3
-+ 5
-+33 total bytes used by duplicates:
-+Total used: 33 bytes (0 KiB, 0 MiB, 0 GiB)
-diff --git a/tests/test.72 b/tests/test.72
-index ba1cc70..51e536e 100755
---- a/tests/test.72
-+++ b/tests/test.72
-@@ -12,7 +12,7 @@ checkrv $?
- DESC="report"
- $DUPD_CMD report --cut `pwd`/files8/ | grep -v "Duplicate report from database" > nreport
- checkrv $?
--check_nreport output.72
-+check_nreport output.72~
-
- (cd ./files8 && ./clean_files)
-