summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirgil Dupras2015-06-08 22:02:19 +0000
committerVirgil Dupras2015-06-08 22:02:19 +0000
commit31955a524ef12e9ae06282f077a7443a154a0ff9 (patch)
tree16b53b4193fe6f8566229cb8fbbd4896f7bfe94f
downloadaur-31955a524ef12e9ae06282f077a7443a154a0ff9.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de222bc7bc7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dupeguru-se
+ pkgdesc = Find duplicate files on your system
+ pkgver = 3.9.1
+ pkgrel = 1
+ url = http://www.hardcoded.net/dupeguru/
+ arch = any
+ license = BSD
+ makedepends = python-sphinx
+ depends = python
+ depends = python-pyqt5
+ depends = libxkbcommon-x11
+ source = http://download.hardcoded.net/dupeguru-se-src-3.9.1.tar.gz
+ md5sums = 8f78859b3a18455339e7919fc4d684ce
+
+pkgname = dupeguru-se
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ad544ce2378
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..505838d936ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
+pkgname=dupeguru-se
+pkgver=3.9.1
+pkgrel=1
+pkgdesc="Find duplicate files on your system"
+arch=(any)
+url="http://www.hardcoded.net/dupeguru/"
+license=('BSD')
+depends=('python' 'python-pyqt5' 'libxkbcommon-x11')
+makedepends=(
+ python-sphinx
+)
+source=(
+ http://download.hardcoded.net/$pkgname-src-$pkgver.tar.gz
+)
+md5sums=(
+ '8f78859b3a18455339e7919fc4d684ce'
+)
+
+build() {
+ cd "$srcdir"
+ python3 -m venv env --system-site-packages
+ source env/bin/activate
+ python -m pip install --no-index --find-links=deps -r requirements.txt
+ source env/bin/activate
+ msg "Starting build..."
+ python configure.py --edition se
+ python build.py --clean
+}
+
+package() {
+ cd "$srcdir"
+
+ python package.py --arch-pkg
+ cd "build/${pkgname}-arch"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ mv ${pkgname}.desktop "${pkgdir}/usr/share/applications"
+
+ mkdir -p "$pkgdir/usr/share/${pkgname}"
+ cp -a * "$pkgdir/usr/share/${pkgname}/"
+ chmod a+x "$pkgdir/usr/share/${pkgname}/run.py"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s ../share/${pkgname}/run.py "$pkgdir/usr/bin/${pkgname}"
+}