summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2021-12-20 00:32:28 +0100
committerfuan_k2021-12-20 00:32:28 +0100
commit63d4a40b88a59300834468c50c9b1bc2f1743f6a (patch)
tree1ab88a20d393c2fc20bf230093bc5a8bb4abf847
parenta12b115804431b1bb9aa49a2b1f845bfd142bf04 (diff)
downloadaur-63d4a40b88a59300834468c50c9b1bc2f1743f6a.tar.gz
Work around polib update
* Update requirements.txt to fetch the latest polib version. This may or may not fix version satisfaction issues some users have reported (probably not). * Remove python-send2trash from deps because it is not available in the AUR anymore (we still get it from pip anyway). * Fix unused "deps" index file path. * Add python-pip as dependency.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8add3452453c..8630b5d751ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dupeguru
pkgdesc = Find duplicate files with various contents, using perceptual diff for pictures
pkgver = 4.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://dupeguru.voltaicideas.net/
arch = any
license = GPL3
@@ -10,9 +10,9 @@ pkgbase = dupeguru
depends = python
depends = python-pyqt5
depends = python-polib
- depends = python-send2trash
depends = python-hsaudiotag3k
depends = libxkbcommon-x11
+ depends = python-pip
provides = dupeguru
conflicts = dupeguru-git
conflicts = dupeguru-se
@@ -22,4 +22,3 @@ pkgbase = dupeguru
md5sums = a88af36a661c813874bb6a2b8d5becbc
pkgname = dupeguru
-
diff --git a/PKGBUILD b/PKGBUILD
index 62345b4693d9..64c73c963d1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,30 @@
# Contributor: Virgil Dupras <hsoft@hardcoded.net>
pkgname=dupeguru
pkgver=4.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Find duplicate files with various contents, using perceptual diff for pictures"
arch=('any')
url="https://dupeguru.voltaicideas.net/"
license=('GPL3')
-depends=('python' 'python-pyqt5' 'python-polib' 'python-send2trash' 'python-hsaudiotag3k'
- 'libxkbcommon-x11')
+depends=('python' 'python-pyqt5' 'python-polib' 'python-hsaudiotag3k'
+ 'libxkbcommon-x11' 'python-pip')
makedepends=('python-distro' 'python-sphinx')
source=( https://github.com/arsenetar/${pkgname}/archive/refs/tags/${pkgver}.tar.gz )
md5sums=('a88af36a661c813874bb6a2b8d5becbc')
provides=("dupeguru")
conflicts=("dupeguru-git" "dupeguru-se" "dupeguru-pe" "dupeguru-me")
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i -E 's/polib.*/polib>=1.1.0/g' requirements.txt
+}
+
build() {
cd "${pkgname}-${pkgver}"
# Instead of doing the full ./bootstrap.sh
python3 -m venv env --system-site-packages
source env/bin/activate
- python3 -m pip install --no-index --find-links=deps -r requirements.txt
+ python3 -m pip install -r requirements.txt
msg "Starting build..."
python build.py --clean
}