summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2018-12-07 05:55:44 +0100
committerfuan_k2018-12-07 05:55:44 +0100
commita3d46ee23b5c575295d9a58321f7c069f444fbd7 (patch)
treef875d2ea17e887b7d07da4ec55b2de6c2e6336d3
parent97b6660ef21bd5b2b9123d1c94803fbd82ed89a5 (diff)
downloadaur-a3d46ee23b5c575295d9a58321f7c069f444fbd7.tar.gz
Fetch hsaudiotag3k with pip instead of AUR
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0331e7e82a61..47823c3a8208 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dupeguru
pkgdesc = Find duplicate files on your system
pkgver = 4.0.3
- pkgrel = 5
+ pkgrel = 6
url = https://dupeguru.voltaicideas.net/
arch = any
license = BSD
@@ -11,7 +11,6 @@ pkgbase = dupeguru
depends = libxkbcommon-x11
depends = python-polib
depends = python-send2trash
- depends = python-hsaudiotag3k
provides = dupeguru
conflicts = dupeguru-se
conflicts = dupeguru-pe
diff --git a/PKGBUILD b/PKGBUILD
index 9eb75caa17dd..cc308189254a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
pkgname=dupeguru
pkgver=4.0.3
-pkgrel=5
+pkgrel=6
pkgdesc="Find duplicate files on your system"
arch=(any)
url="https://dupeguru.voltaicideas.net/"
license=('BSD')
-depends=('python' 'python-pyqt5' 'libxkbcommon-x11' 'python-polib' 'python-send2trash' 'python-hsaudiotag3k')
+depends=('python' 'python-pyqt5' 'libxkbcommon-x11' 'python-polib' 'python-send2trash')
makedepends=(
python-sphinx
)
@@ -34,9 +34,11 @@ prepare(){
build() {
cd "$srcdir"
+ # Instead of doing the full ./bootstrap.sh
python3 -m venv env --system-site-packages
source env/bin/activate
- python -m pip install --no-index --find-links=deps -r requirements.txt
+ #python -m pip install --no-index --find-links=deps -r requirements.txt
+ ./env/bin/pip install -r requirements.txt
source env/bin/activate
msg "Starting build..."
python build.py --clean