summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2020-12-10 19:52:55 +0100
committerfuan_k2020-12-10 19:52:55 +0100
commita8cdc49e6b23e89eb08a12e77fca03e020ef6c94 (patch)
tree764b093f493e09eca41d714861ecdda98a366626
parent2a3d89475a4bcf986b744821fbaa56817983cc00 (diff)
downloadaur-a8cdc49e6b23e89eb08a12e77fca03e020ef6c94.tar.gz
Update to 4.1.0
* Upstream maintainer is taking too long to merge the patches that would fix the upstream master branch * Temporarily point to alternate source repository for a source release of 4.1.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdb72e8c1bfc..7ad8312e4352 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = dupeguru
pkgdesc = Find duplicate files on your system
- pkgver = 4.0.4
- pkgrel = 4
+ pkgver = 4.1.0
+ pkgrel = 1
url = https://dupeguru.voltaicideas.net/
arch = x86_64
- license = BSD
+ license = GPL3
makedepends = python-sphinx
depends = python
depends = python-pyqt5
depends = libxkbcommon-x11
depends = python-send2trash
provides = dupeguru
+ conflicts = dupeguru-git
conflicts = dupeguru-se
conflicts = dupeguru-pe
conflicts = dupeguru-me
- source = https://github.com/arsenetar/dupeguru/releases/download/4.0.4/dupeguru-src-4.0.4_RC.tar.gz
- md5sums = 85184ae7fa32a917541d359638123767
+ source = https://github.com/glubsy/dupeguru/releases/download/4.1.0-alpha/dupeguru-src-4.1.0-alpha.tar.xz
+ md5sums = 6faf275a1e1be0c42e5faa32d2ddf7ab
pkgname = dupeguru
diff --git a/PKGBUILD b/PKGBUILD
index b6dfab2041db..81f8d43f1ad0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,35 @@
# Maintainer: Bijaya Dangol <dangoldbj23@gmail.com>
# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
pkgname=dupeguru
-pkgver=4.0.4
-pkgrel=4
+pkgver=4.1.0
+_pkgver="${pkgver}-alpha"
+pkgrel=1
pkgdesc="Find duplicate files on your system"
arch=('x86_64')
url="https://dupeguru.voltaicideas.net/"
-license=('BSD')
+license=('GPL3')
depends=('python' 'python-pyqt5' 'libxkbcommon-x11' 'python-send2trash')
makedepends=(
python-sphinx
)
source=(
- https://github.com/arsenetar/${pkgname}/releases/download/${pkgver}/dupeguru-src-${pkgver}_RC.tar.gz
+ https://github.com/glubsy/${pkgname}/releases/download/${_pkgver}/dupeguru-src-${_pkgver}.tar.xz
)
md5sums=(
- '85184ae7fa32a917541d359638123767'
+ '6faf275a1e1be0c42e5faa32d2ddf7ab'
)
provides=("dupeguru")
-conflicts=("dupeguru-se" "dupeguru-pe" "dupeguru-me")
+conflicts=("dupeguru-git" "dupeguru-se" "dupeguru-pe" "dupeguru-me")
prepare() {
- cd "$srcdir"
+ cd "${srcdir}"
sed -i "s/hsaudiotag3k>=1.1.3/hsaudiotag3k>=1.1.*/g" requirements.txt
# replace hardcoded icon path in .desktop file
sed -i "s/\(.*iconpath.*\"\).*\"/\1dupeguru\"/g" pkg/arch/dupeguru.json
}
build() {
- cd "$srcdir"
+ cd "${srcdir}"
# Instead of doing the full ./bootstrap.sh
python3 -m venv env --system-site-packages
source env/bin/activate
@@ -41,7 +42,7 @@ build() {
}
package() {
- cd "$srcdir"
+ cd "${srcdir}"
cp -R "help" "build"
cp -R "locale" "build"