summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2021-01-30 19:54:57 +0100
committerfuan_k2021-01-30 19:54:57 +0100
commite41c5c2e5d5f887d83727a8e6df8ab1dbb168fb6 (patch)
treedfaf7d63aa29d83af2d8af08541e407b2d119910
parenta7313179e37e72b871bead816be1bb984a86c528 (diff)
downloadaur-e41c5c2e5d5f887d83727a8e6df8ab1dbb168fb6.tar.gz
Update source back to upstream
* Revert back to upstream source archive since new release is now available * Remove prepare step since the changes have been merged upstream * Revert back to arch=any because the package should be able to build on any architecture
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ed49e2b5f9..e71e2c28b87d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = dupeguru
- pkgdesc = Find duplicate files on your system
+ pkgdesc = Find duplicate files with various contents, using perceptual diff for pictures
pkgver = 4.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://dupeguru.voltaicideas.net/
- arch = x86_64
+ arch = any
license = GPL3
makedepends = python-sphinx
depends = python
@@ -14,8 +14,8 @@ pkgbase = dupeguru
conflicts = dupeguru-se
conflicts = dupeguru-pe
conflicts = dupeguru-me
- source = https://github.com/glubsy/dupeguru/releases/download/4.1.0-alpha/dupeguru-src-4.1.0-alpha.tar.xz
- md5sums = 6faf275a1e1be0c42e5faa32d2ddf7ab
+ source = https://github.com/arsenetar/dupeguru/archive/4.1.0.tar.gz
+ md5sums = eee02386ea18f592502c05049eda9f99
pkgname = dupeguru
diff --git a/PKGBUILD b/PKGBUILD
index 429f87588e2e..1122ec82db1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,45 +3,36 @@
# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
pkgname=dupeguru
pkgver=4.1.0
-_pkgver="${pkgver}-alpha"
-pkgrel=2
-pkgdesc="Find duplicate files on your system"
-arch=('x86_64')
+pkgrel=3
+pkgdesc="Find duplicate files with various contents, using perceptual diff for pictures"
+arch=('any')
url="https://dupeguru.voltaicideas.net/"
license=('GPL3')
depends=('python' 'python-pyqt5' 'libxkbcommon-x11')
makedepends=('python-sphinx')
-source=(
- https://github.com/glubsy/${pkgname}/releases/download/${_pkgver}/dupeguru-src-${_pkgver}.tar.xz
-)
-md5sums=(
- '6faf275a1e1be0c42e5faa32d2ddf7ab'
-)
+source=( https://github.com/arsenetar/${pkgname}/archive/${pkgver}.tar.gz )
+md5sums=('eee02386ea18f592502c05049eda9f99')
provides=("dupeguru")
conflicts=("dupeguru-git" "dupeguru-se" "dupeguru-pe" "dupeguru-me")
-prepare() {
- cd "${srcdir}"
- sed -i "s/hsaudiotag3k>=1.1.3/hsaudiotag3k>=1.1.*/g" requirements.txt
- # replace hardcoded icon path in .desktop file
- sed -i "s/\(.*iconpath.*\"\).*\"/\1dupeguru\"/g" pkg/arch/dupeguru.json
-}
-
build() {
- cd "${srcdir}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Instead of doing the full ./bootstrap.sh
python3 -m venv env --system-site-packages
source env/bin/activate
+ # FIXME use available packages from the AUR instead of pypi
+ msg "Installing dependencies in a virtual environment..."
python3 -m pip install -r requirements.txt
msg "Starting build..."
python build.py --clean
}
package() {
- cd "${srcdir}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
cp -R "help" "build"
cp -R "locale" "build"
+ msg "Starting package..."
python package.py --arch-pkg
cd "build/${pkgname}-arch"