summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirgil Dupras2015-06-08 22:03:57 +0000
committerVirgil Dupras2015-06-08 22:03:57 +0000
commit8f68efd0aee168f7eb64e9c3f1fa2a9f563737a0 (patch)
treeb300cf1f460fcc057af50b10e1e5c350f39de80e
downloadaur-8f68efd0aee168f7eb64e9c3f1fa2a9f563737a0.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a66bc55b1f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dupeguru-me
+ pkgdesc = Find duplicate songs on your system
+ pkgver = 6.8.1
+ pkgrel = 1
+ url = http://www.hardcoded.net/dupeguru_me/
+ arch = any
+ license = BSD
+ makedepends = python-sphinx
+ makedepends = gcc
+ depends = python
+ depends = python-pyqt5
+ depends = libxkbcommon-x11
+ source = http://download.hardcoded.net/dupeguru-me-src-6.8.1.tar.gz
+ md5sums = 70b5dd7f258dcdb2584521e03aedb8bd
+
+pkgname = dupeguru-me
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ad544ce2378
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.xz
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3b9b728e7ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
+pkgname=dupeguru-me
+pkgver=6.8.1
+pkgrel=1
+pkgdesc="Find duplicate songs on your system"
+arch=(any)
+url="http://www.hardcoded.net/dupeguru_me/"
+license=('BSD')
+depends=('python' 'python-pyqt5' 'libxkbcommon-x11')
+makedepends=(
+ python-sphinx
+ gcc
+)
+source=(
+ http://download.hardcoded.net/$pkgname-src-$pkgver.tar.gz
+)
+md5sums=(
+ '70b5dd7f258dcdb2584521e03aedb8bd'
+)
+
+build() {
+ cd "$srcdir"
+ python3 -m venv env --system-site-packages
+ source env/bin/activate
+ python -m pip install --no-index --find-links=deps -r requirements.txt
+ msg "Starting build..."
+ python configure.py --edition me
+ python build.py --clean
+}
+
+package() {
+ cd "$srcdir"
+
+ python package.py --arch-pkg
+ cd "build/${pkgname}-arch"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ mv ${pkgname}.desktop "${pkgdir}/usr/share/applications"
+
+ mkdir -p "$pkgdir/usr/share/${pkgname}"
+ cp -a * "$pkgdir/usr/share/${pkgname}/"
+ chmod a+x "$pkgdir/usr/share/${pkgname}/run.py"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s ../share/${pkgname}/run.py "$pkgdir/usr/bin/${pkgname}"
+}