summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2019-12-17 21:08:27 +0000
committerGr3q2019-12-17 21:08:27 +0000
commit165c73eda79e7022812239c315adb21ff309912f (patch)
tree6c029d77f8383138103999aab5706ce0740abe40
downloadaur-165c73eda79e7022812239c315adb21ff309912f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
-rw-r--r--duplex.patch151
3 files changed, 202 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21357db604e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = duplex
+ pkgdesc = Duplex Printing Emulation System
+ pkgver = 0.3.1.1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/duplexpr/
+ arch = any
+ license = GPL2
+ depends = cups
+ depends = yad
+ depends = enscript
+ depends = poppler
+ depends = ghostscript
+ optdepends = xclip: Clipboard support
+ optdepends = trash-cli: Move to trash support
+ source = https://sourceforge.net/projects/duplexpr/files/duplex_0_3_1_1.tar.gz
+ source = duplex.patch
+ sha512sums = b9ba396e672ede5f436f0b1e124f84fe8f28fdf109652c5ae1be4ef4c52493d444586db54860753cbbc6ec1623fa190603abcd4a0d13597f620b49caf5503feb
+ sha512sums = 2d5864ee4821073ed0216d248dc455a70cd98f454034c38075203205ab42e98cd02c7c33d0f73298642d3437bf7142d229b2c56e9881783db9e6efa754bc66e4
+
+pkgname = duplex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c09aa00414d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
+
+pkgname=duplex
+pkgver=0.3.1.1
+pkgrel=1
+pkgdesc='Duplex Printing Emulation System'
+arch=('any')
+url='https://sourceforge.net/projects/duplexpr/'
+license=('GPL2')
+depends=('cups' 'yad' 'enscript' 'poppler' 'ghostscript')
+optdepends=('xclip: Clipboard support' 'trash-cli: Move to trash support')
+source=(
+ 'https://sourceforge.net/projects/duplexpr/files/duplex_0_3_1_1.tar.gz'
+ 'duplex.patch')
+sha512sums=(
+ 'b9ba396e672ede5f436f0b1e124f84fe8f28fdf109652c5ae1be4ef4c52493d444586db54860753cbbc6ec1623fa190603abcd4a0d13597f620b49caf5503feb'
+ '2d5864ee4821073ed0216d248dc455a70cd98f454034c38075203205ab42e98cd02c7c33d0f73298642d3437bf7142d229b2c56e9881783db9e6efa754bc66e4')
+
+prepare() {
+ cd "$srcdir/duplex_0_3_1_1"
+ patch --strip=1 --input=../duplex.patch
+}
+
+package() {
+ install -dm 755 "${pkgdir}"/{usr/share/duplex,usr/share/licenses/duplex,usr/bin/}
+ cd "$srcdir/duplex_0_3_1_1"
+ cp -dr --no-preserve='ownership' dplx duplex dot.duplexpr Test_File.pdf klprm kmprb kmprb_one kmprbatches krmpq mpr mprb dprint dprintf dprintm rmpq pqnext "${pkgdir}"/usr/share/duplex/
+ cp -dr --no-preserve='ownership' license.txt "${pkgdir}"/usr/share/licenses/duplex
+ ln -sf /usr/share/duplex/dplx "${pkgdir}"/usr/bin/duplex
+}
diff --git a/duplex.patch b/duplex.patch
new file mode 100644
index 000000000000..b2f6077190aa
--- /dev/null
+++ b/duplex.patch
@@ -0,0 +1,151 @@
+diff --unified --recursive --text duplex_0_3_1_1/dplx duplex_0_3_1_1new/dplx
+--- duplex_0_3_1_1/dplx 2018-03-24 01:45:23.000000000 +0000
++++ duplex_0_3_1_1new/dplx 2019-12-17 20:37:58.669987000 +0000
+@@ -40,8 +40,8 @@
+
+ function mypath () {
+ ## Get the real path of the calling script
+- ## From: https://stackoverflow.com/questions/59895/getting-the-source-directory-of-a-bash-script-from-within/246128#246128
+- my_path="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd)"
++ ## From: https://stackoverflow.com/a/1482133
++ my_path="$( cd "$( dirname "$(readlink -f "$0")" )" && pwd)"
+ }
+
+ ## Set current print strategy
+@@ -96,13 +96,13 @@
+ e="" # Null string so duplex is called
+ ## e="echo " #For debugging - disable call to duplex
+ duplex="${script_path}/duplex" # Production version
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+
+ ## Access the duplexpr configuration file
+ if [[ ! -r $config ]] ## debug
+ then
+- echo "Missing config file ${config}"
+- exit "${script_error}"
++ mkdir -p "${HOME}/.config/duplex"
++ cp "${script_path}/dot.duplexpr" "$config"
+ fi
+
+ source "${config}"
+diff --unified --recursive --text duplex_0_3_1_1/dprint duplex_0_3_1_1new/dprint
+--- duplex_0_3_1_1/dprint 2018-03-24 01:45:23.000000000 +0000
++++ duplex_0_3_1_1new/dprint 2019-12-17 20:38:09.046422000 +0000
+@@ -75,7 +75,7 @@
+ ORIENTATION="-R" ## portrait printing
+
+ script_name="$(basename $0)" ## path stripped name of this script
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+ ## Access the duplexpr configuration file
+ if [[ ! -r "${config}" ]]
+ then
+diff --unified --recursive --text duplex_0_3_1_1/dprintf duplex_0_3_1_1new/dprintf
+--- duplex_0_3_1_1/dprintf 2018-03-24 01:45:23.000000000 +0000
++++ duplex_0_3_1_1new/dprintf 2019-12-17 20:38:19.606187000 +0000
+@@ -33,7 +33,7 @@
+ exit 1
+ fi
+
+-config="${HOME}/.duplexpr"
++config=${HOME}/.config/duplex/duplexpr.conf"
+
+ ## Access the duplexpr configuration file
+ if [[ ! -r $config ]] ## debug
+diff --unified --recursive --text duplex_0_3_1_1/duplex duplex_0_3_1_1new/duplex
+--- duplex_0_3_1_1/duplex 2018-03-24 01:45:23.000000000 +0000
++++ duplex_0_3_1_1new/duplex 2019-12-17 20:38:42.552342000 +0000
+@@ -339,7 +339,7 @@
+
+ script_error=9
+ fake_print_job_number=0 ## for use with fake version of lp for testing
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+
+ ## enscript parameters
+ ## In moderate point sizes (12+), the header font may need to be proportional
+diff --unified --recursive --text duplex_0_3_1_1/kmprb duplex_0_3_1_1new/kmprb
+--- duplex_0_3_1_1/kmprb 2018-08-02 08:10:39.000000000 +0100
++++ duplex_0_3_1_1new/kmprb 2019-12-17 20:39:04.201859000 +0000
+@@ -344,7 +344,7 @@
+ yyes="OK"
+ yno="Cancel"
+
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+ default_batch_size=16 ## Offer this batch size by default if there are at least that many sheets to print
+ ## defined here in case it's not in the config file
+
+diff --unified --recursive --text duplex_0_3_1_1/kmprbatches duplex_0_3_1_1new/kmprbatches
+--- duplex_0_3_1_1/kmprbatches 2018-07-31 08:46:45.000000000 +0100
++++ duplex_0_3_1_1new/kmprbatches 2019-12-17 20:39:25.561383000 +0000
+@@ -166,7 +166,7 @@
+
+ ##source $HOME/bin/bash_trace ## debug - TRACE
+ tp='/tmp'
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+ script_error=9
+ dsptime_error=30 ## yad timeout error messages
+ dsptime_short=5 ## yad timeout error messages
+diff --unified --recursive --text duplex_0_3_1_1/kmprb_one duplex_0_3_1_1new/kmprb_one
+--- duplex_0_3_1_1/kmprb_one 2018-03-24 01:47:48.000000000 +0000
++++ duplex_0_3_1_1new/kmprb_one 2019-12-17 20:39:37.401119000 +0000
+@@ -186,7 +186,7 @@
+ script_path="${my_path}" ## make sure we can find other scripts
+ yyes="OK"
+ yno="Cancel"
+-config="${HOME}/.duplexpr"
++config=${HOME}/.config/duplex/duplexpr.conf"
+
+ trap 'user_abort' 2 ## Call user_abort() if user presses ctrl-c
+
+diff --unified --recursive --text duplex_0_3_1_1/krmpq duplex_0_3_1_1new/krmpq
+--- duplex_0_3_1_1/krmpq 2018-08-02 08:16:48.000000000 +0100
++++ duplex_0_3_1_1new/krmpq 2019-12-17 20:39:54.840730000 +0000
+@@ -70,7 +70,7 @@
+ dsptime_long=10 ## yad timeout for exception messages
+ dsptime_error=30 ## yad timeout for error messages
+
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+ rc=0 ## return code if not set elsewhere
+
+ ## Access the duplexpr configuration file
+diff --unified --recursive --text duplex_0_3_1_1/mprb duplex_0_3_1_1new/mprb
+--- duplex_0_3_1_1/mprb 2018-06-11 09:38:45.000000000 +0100
++++ duplex_0_3_1_1new/mprb 2019-12-17 20:40:14.853617000 +0000
+@@ -394,7 +394,7 @@
+ yyes="OK"
+ yno="Cancel"
+
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+
+ ## enscript parameters
+ ## In moderate point sizes (12+), the header font may need to be proportional
+diff --unified --recursive --text duplex_0_3_1_1/pqnext duplex_0_3_1_1new/pqnext
+--- duplex_0_3_1_1/pqnext 2018-07-22 11:24:17.000000000 +0100
++++ duplex_0_3_1_1new/pqnext 2019-12-17 20:40:27.470003000 +0000
+@@ -46,7 +46,7 @@
+ shift
+ fi
+
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+
+ ## Access the duplexpr configuration file
+ if [[ ! -r "${config}" ]]
+diff --unified --recursive --text duplex_0_3_1_1/rmpq duplex_0_3_1_1new/rmpq
+--- duplex_0_3_1_1/rmpq 2018-07-30 08:49:42.000000000 +0100
++++ duplex_0_3_1_1new/rmpq 2019-12-17 20:40:40.033056000 +0000
+@@ -24,7 +24,7 @@
+ }
+
+ script_name=$(basename $0) ## path stripped name of this script
+-config="${HOME}/.duplexpr"
++config="${HOME}/.config/duplex/duplexpr.conf"
+
+ e="" ## Actually delete files
+ ##e="echo " ## debug - just say we did - DRYRUN