summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Langlois2020-04-05 14:12:03 -0400
committerEric Langlois2020-04-05 14:12:03 -0400
commitb7bd9951fe81194ada29db49dfa050e2f3bcda32 (patch)
tree95b9cea510856efcaf10ec372870476d5341b170
parentd0705293f996f50ddc36b63cf9af71f3d2930936 (diff)
downloadaur-b7bd9951fe81194ada29db49dfa050e2f3bcda32.tar.gz
Services start duplicacy-web in background mode
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--duplicacy-web.service2
-rw-r--r--duplicacy-web@.service2
4 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f24d66c36b0..0a71b2ea5573 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = duplicacy-web
pkgdesc = Cross-platform cloud backup tool with a web GUI
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://duplicacy.com/
arch = x86_64
arch = arm
@@ -9,13 +9,13 @@ pkgbase = duplicacy-web
source = duplicacy-web@.service
source = duplicacy-web.service
source = LICENSE
- sha256sums = badfbf6d88480577ff3f91bfcc14e036eabd4cb04a879704294d40da02668ea9
- sha256sums = 8e6522574d0132d3f908961cc8c4c1f592738c7372d87f9ac4463c6650955be7
+ sha256sums = f169ca1196a3d99661b5fdf9b61d18c3f7a1341f6d90c1411874a9ebfecce10a
+ sha256sums = 33325dd4c621676af89c4f6c27105fb16e0b9b00e962e6496f7d532f907646bf
sha256sums = f6da608f2babc6db66aed83e0ba7e1ce130680b15d2dbe01019cb01c88abc7db
source_x86_64 = duplicacy-web::https://acrosync.com/duplicacy-web/duplicacy_web_linux_x64_1.2.1
sha256sums_x86_64 = 9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f
source_arm = duplicacy-web::https://acrosync.com/duplicacy-web/duplicacy_web_linux_arm_1.2.1
- sha256sums_arm = 30fd83948764f74b39be5d32b5e4d5ff97986cdaa4254ce8c6344aaf495c5597
+ sha256sums_arm = 9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f
pkgname = duplicacy-web
diff --git a/PKGBUILD b/PKGBUILD
index 37c5a48dcb0d..4b2e27f46d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eric Langlois <eric@langlois.xyz>
pkgname=duplicacy-web
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-platform cloud backup tool with a web GUI"
arch=('x86_64' 'arm')
url="https://duplicacy.com/"
@@ -11,13 +11,13 @@ makedepends=()
source=("$pkgname@.service"
"$pkgname.service"
"LICENSE")
-sha256sums=(badfbf6d88480577ff3f91bfcc14e036eabd4cb04a879704294d40da02668ea9
- 8e6522574d0132d3f908961cc8c4c1f592738c7372d87f9ac4463c6650955be7
- f6da608f2babc6db66aed83e0ba7e1ce130680b15d2dbe01019cb01c88abc7db)
source_x86_64=("$pkgname::https://acrosync.com/$pkgname/${pkgname//-/_}_linux_x64_$pkgver")
-sha256sums_x86_64=(9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f)
source_arm=("$pkgname::https://acrosync.com/$pkgname/${pkgname//-/_}_linux_arm_$pkgver")
-sha256sums_arm=(30fd83948764f74b39be5d32b5e4d5ff97986cdaa4254ce8c6344aaf495c5597)
+sha256sums=('f169ca1196a3d99661b5fdf9b61d18c3f7a1341f6d90c1411874a9ebfecce10a'
+ '33325dd4c621676af89c4f6c27105fb16e0b9b00e962e6496f7d532f907646bf'
+ 'f6da608f2babc6db66aed83e0ba7e1ce130680b15d2dbe01019cb01c88abc7db')
+sha256sums_x86_64=('9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f')
+sha256sums_arm=('9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f')
package() {
install -m755 -D -t "$pkgdir/usr/bin" "$pkgname"
diff --git a/duplicacy-web.service b/duplicacy-web.service
index 960ae69a6ad4..4d88d62f0a02 100644
--- a/duplicacy-web.service
+++ b/duplicacy-web.service
@@ -4,7 +4,7 @@ Documentation=https://duplicacy.com/guide.html
After=network.target
[Service]
-ExecStart=/usr/bin/duplicacy-web
+ExecStart=/usr/bin/duplicacy-web -background -no-tray-icon
Restart=on-failure
# Hardening
diff --git a/duplicacy-web@.service b/duplicacy-web@.service
index bb66fb77cf77..8503ab916095 100644
--- a/duplicacy-web@.service
+++ b/duplicacy-web@.service
@@ -5,7 +5,7 @@ After=network.target
[Service]
User=%i
-ExecStart=/usr/bin/duplicacy-web
+ExecStart=/usr/bin/duplicacy-web -background -no-tray-icon
Restart=on-failure
# Hardening