summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Langlois2020-04-05 01:35:46 -0400
committerEric Langlois2020-04-05 13:26:06 -0400
commitd0705293f996f50ddc36b63cf9af71f3d2930936 (patch)
treef981ad16ab66aac4845992e6cb68e28b59af80d2
downloadaur-d0705293f996f50ddc36b63cf9af71f3d2930936.tar.gz
Initial duplicacy-web PKGBUILD, LICENSE, and service files
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--LICENSE18
-rw-r--r--PKGBUILD27
-rw-r--r--duplicacy-web.service17
-rw-r--r--duplicacy-web@.service19
6 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f24d66c36b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = duplicacy-web
+ pkgdesc = Cross-platform cloud backup tool with a web GUI
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://duplicacy.com/
+ arch = x86_64
+ arch = arm
+ license = custom
+ source = duplicacy-web@.service
+ source = duplicacy-web.service
+ source = LICENSE
+ sha256sums = badfbf6d88480577ff3f91bfcc14e036eabd4cb04a879704294d40da02668ea9
+ sha256sums = 8e6522574d0132d3f908961cc8c4c1f592738c7372d87f9ac4463c6650955be7
+ sha256sums = f6da608f2babc6db66aed83e0ba7e1ce130680b15d2dbe01019cb01c88abc7db
+ source_x86_64 = duplicacy-web::https://acrosync.com/duplicacy-web/duplicacy_web_linux_x64_1.2.1
+ sha256sums_x86_64 = 9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f
+ source_arm = duplicacy-web::https://acrosync.com/duplicacy-web/duplicacy_web_linux_arm_1.2.1
+ sha256sums_arm = 30fd83948764f74b39be5d32b5e4d5ff97986cdaa4254ce8c6344aaf495c5597
+
+pkgname = duplicacy-web
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1c5b1fb969e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/*
+pkg/*
+*.pkg.tar.xz
+duplicacy-web
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1506d9b83e64
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,18 @@
+Copyright 2019 Acrosync LLC
+
+Duplicacy Web Edition
+
+This is the full-featured web-based GUI frontend supporting all major operations
+(backup, restore, check, copy, and prune) as well as other features such as
+scheduling and email notifications. It also integrates a dashboard to provide
+a graphical view of the status of storages and backups.
+
+This version can be used without a license if you only need the restore, check,
+copy, and prune operations. If you do need to run backups, a fully functional
+30-day trial license will be automatically downloaded to enable the backup
+operation. After 30 days, a personal or commercial license can be purchased from
+the licenses [0] page.
+
+[0]: https://duplicacy.com/licenses
+
+License text retrieved from https://duplicacy.com/download.html on 2020-04-04.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37c5a48dcb0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Eric Langlois <eric@langlois.xyz>
+pkgname=duplicacy-web
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Cross-platform cloud backup tool with a web GUI"
+arch=('x86_64' 'arm')
+url="https://duplicacy.com/"
+license=('custom')
+depends=()
+makedepends=()
+source=("$pkgname@.service"
+ "$pkgname.service"
+ "LICENSE")
+sha256sums=(badfbf6d88480577ff3f91bfcc14e036eabd4cb04a879704294d40da02668ea9
+ 8e6522574d0132d3f908961cc8c4c1f592738c7372d87f9ac4463c6650955be7
+ f6da608f2babc6db66aed83e0ba7e1ce130680b15d2dbe01019cb01c88abc7db)
+source_x86_64=("$pkgname::https://acrosync.com/$pkgname/${pkgname//-/_}_linux_x64_$pkgver")
+sha256sums_x86_64=(9381581171503788a9c31c60ea672bf0a0f3fc7d7537f83c24b318fef009b87f)
+source_arm=("$pkgname::https://acrosync.com/$pkgname/${pkgname//-/_}_linux_arm_$pkgver")
+sha256sums_arm=(30fd83948764f74b39be5d32b5e4d5ff97986cdaa4254ce8c6344aaf495c5597)
+
+package() {
+ install -m755 -D -t "$pkgdir/usr/bin" "$pkgname"
+ install -m644 -D -t "$pkgdir/usr/lib/systemd/system" "$pkgname@.service"
+ install -m644 -D -t "$pkgdir/usr/lib/systemd/user" "$pkgname.service"
+ install -m644 -D -t "$pkgdir/usr/share/licenses/$pkgname" "LICENSE"
+}
diff --git a/duplicacy-web.service b/duplicacy-web.service
new file mode 100644
index 000000000000..960ae69a6ad4
--- /dev/null
+++ b/duplicacy-web.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=Duplicacy Web - Cloud Backup with a Web GUI
+Documentation=https://duplicacy.com/guide.html
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/duplicacy-web
+Restart=on-failure
+
+# Hardening
+ProtectSystem=full
+SystemCallArchitectures=native
+MemoryDenyWriteExecute=true
+NoNewPrivileges=true
+
+[Install]
+WantedBy=default.target
diff --git a/duplicacy-web@.service b/duplicacy-web@.service
new file mode 100644
index 000000000000..bb66fb77cf77
--- /dev/null
+++ b/duplicacy-web@.service
@@ -0,0 +1,19 @@
+[Unit]
+Description=Duplicacy Web - Cloud Backup with a Web GUI for %I
+Documentation=https://duplicacy.com/guide.html
+After=network.target
+
+[Service]
+User=%i
+ExecStart=/usr/bin/duplicacy-web
+Restart=on-failure
+
+# Hardening
+ProtectSystem=full
+PrivateDevices=true
+SystemCallArchitectures=native
+MemoryDenyWriteExecute=true
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target