summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2022-12-11 21:39:50 -0500
committerJoey Dumont2022-12-11 21:39:50 -0500
commit5283b0818f8486c92201834da579ba6b4f3cf0ac (patch)
tree8948e6700fc3b0a1589c99c2ad5ececddc01a78b
downloadaur-5283b0818f8486c92201834da579ba6b4f3cf0ac.tar.gz
Initial upload: duplicati-canary-bin 2.0.6.104-5
Move to duplicati-canary-bin.
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD61
-rw-r--r--duplicati-cli9
-rw-r--r--duplicati-user.service12
-rw-r--r--duplicati.env2
-rw-r--r--duplicati.install63
-rw-r--r--duplicati.service13
-rw-r--r--duplicati.sysusers1
-rw-r--r--duplicati.tmpfiles.conf1
9 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..868bef3f6ca9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = duplicati-canary-bin
+ pkgdesc = A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers
+ pkgver = 2.0.6.104
+ pkgrel = 5
+ url = http://duplicati.com
+ install = duplicati.install
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = LGPL
+ makedepends = unzip
+ depends = openssl-1.1
+ depends = gtk-sharp-2
+ depends = mono
+ depends = libappindicator-gtk2
+ optdepends = notify-sharp: for tray notifications
+ conflicts = duplicati-latest
+ replaces = duplicati-latest
+ noextract = duplicati-2.0.6.104_canary_2022-06-15.zip
+ backup = etc/default/duplicati
+ source = https://github.com/duplicati/duplicati/releases/download/v2.0.6.104-2.0.6.104_canary_2022-06-15/duplicati-2.0.6.104_canary_2022-06-15.zip
+ source = duplicati-user.service
+ source = duplicati.service
+ source = duplicati.sysusers
+ source = duplicati.tmpfiles.conf
+ source = duplicati-cli
+ source = duplicati.env
+ sha256sums = 955c6d466a0bb86d9b8f56006ff3b64ed2acae2d5816ebecaa8fe0351145cc3d
+ sha256sums = 5e47acfb251e0fbe4c01bd75ba88a78c497208bf767addb59010baea049dd19f
+ sha256sums = 9e88381d56b462643a152945b81f98d3a7744bdc760fe201aec02a50bccbb5c4
+ sha256sums = b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959
+ sha256sums = b6ca3d280feb753ded94bb44eef821a0dac0c0c7ed7f37dea76d445a64386c86
+ sha256sums = 2e4d337ebd524b312d0efed46a944e68b863ee4f46ee96e3323adb2a193ee3ab
+ sha256sums = 99591e96c340b49b47341315cb42f8ac12ca66dc4d22550e4acd37cce84e8b36
+
+pkgname = duplicati-canary-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92cfaa4c3ba7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Joey Dumont <joey.dumont@gmail.com>
+# Maintainer: Bjorn Neergaard <bjorn@neersighted.com>
+# Contributor: Danny Su <contact@dannysu.com>
+# aarch64 tester: Irissman <irissman@probus.ca>
+# armv7h tester: kauron
+pkgname=duplicati-canary-bin
+pkgver=2.0.6.104
+pkgrel=5
+_date=2022-06-15
+_branch=canary
+pkgdesc="A free backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers"
+url="http://duplicati.com"
+license=('LGPL')
+install=duplicati.install
+source=(
+ # https://updates.duplicati.com/${_branch}/duplicati-${pkgver}_${_branch}_${_date}.zip # duplicati.com seems to be blocked in Russia, see https://aur.archlinux.org/packages/duplicati-latest/#comment-746652
+ "https://github.com/duplicati/duplicati/releases/download/v${pkgver}-${pkgver}_${_branch}_${_date}/duplicati-${pkgver}_${_branch}_${_date}.zip"
+ duplicati-user.service
+ duplicati.service
+ duplicati.sysusers
+ duplicati.tmpfiles.conf
+ duplicati-cli
+ duplicati.env
+)
+noextract=(
+ "duplicati-${pkgver}_${_branch}_${_date}.zip"
+ )
+backup=(
+ etc/default/duplicati
+)
+sha256sums=('955c6d466a0bb86d9b8f56006ff3b64ed2acae2d5816ebecaa8fe0351145cc3d'
+ '5e47acfb251e0fbe4c01bd75ba88a78c497208bf767addb59010baea049dd19f'
+ '9e88381d56b462643a152945b81f98d3a7744bdc760fe201aec02a50bccbb5c4'
+ 'b9389b399467f3e02aa8e76bb98f6efbca1166fbc4d0bdf939493f8403462959'
+ 'b6ca3d280feb753ded94bb44eef821a0dac0c0c7ed7f37dea76d445a64386c86'
+ '2e4d337ebd524b312d0efed46a944e68b863ee4f46ee96e3323adb2a193ee3ab'
+ '99591e96c340b49b47341315cb42f8ac12ca66dc4d22550e4acd37cce84e8b36')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
+depends=(openssl-1.1 gtk-sharp-2 mono libappindicator-gtk2)
+makedepends=(unzip)
+optdepends=('notify-sharp: for tray notifications')
+replaces=(duplicati-latest)
+conflicts=(duplicati-latest)
+
+package() {
+
+ # Install the service.
+ install -Dm644 duplicati.service "${pkgdir}/usr/lib/systemd/system/duplicati.service"
+ install -Dm644 duplicati-user.service "${pkgdir}/usr/lib/systemd/user/duplicati.service"
+ install -Dm644 "$srcdir/duplicati.sysusers" "$pkgdir/usr/lib/sysusers.d/duplicati.conf"
+ install -Dm644 "$srcdir/duplicati.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/duplicati.conf"
+ install -Dm644 "$srcdir/duplicati.env" "$pkgdir/etc/default/duplicati"
+
+ # Install the CLI wrapper.
+ mkdir -p "${pkgdir}/usr/bin"
+ install -D -m755 duplicati-cli "${pkgdir}/usr/bin"
+
+ # Install the program.
+ mkdir -p "${pkgdir}"/opt/duplicati
+ unzip -a "duplicati-${pkgver}_${_branch}_${_date}.zip" -d "${pkgdir}"/opt/duplicati
+}
diff --git a/duplicati-cli b/duplicati-cli
new file mode 100644
index 000000000000..b1d770d88635
--- /dev/null
+++ b/duplicati-cli
@@ -0,0 +1,9 @@
+#!/bin/bash
+INSTALLDIR=/opt/duplicati/
+export LD_LIBRARY_PATH="${INSTALLDIR}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+export MONO_PATH=$MONO_PATH:${INSTALLDIR}
+
+EXE_FILE=${INSTALLDIR}/Duplicati.CommandLine.exe
+APP_NAME=Duplicati.CommandLine
+
+exec -a "$APP_NAME" mono "$EXE_FILE" "$@"
diff --git a/duplicati-user.service b/duplicati-user.service
new file mode 100644
index 000000000000..7e716d060a87
--- /dev/null
+++ b/duplicati-user.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Duplicati
+
+[Service]
+ExecStartPre=/usr/bin/sleep 5
+ExecStart=/usr/bin/mono /opt/duplicati/Duplicati.GUI.TrayIcon.exe --webservice-port=8200
+Restart=on-abort
+Environment=AUTOUPDATER_Duplicati_SKIP_UPDATE=1
+
+[Install]
+WantedBy=default.target
+
diff --git a/duplicati.env b/duplicati.env
new file mode 100644
index 000000000000..c173fcc0fd09
--- /dev/null
+++ b/duplicati.env
@@ -0,0 +1,2 @@
+AUTOUPDATER_Duplicati_SKIP_UPDATE=1
+DUPLICATI_HOME=/var/lib/duplicati \ No newline at end of file
diff --git a/duplicati.install b/duplicati.install
new file mode 100644
index 000000000000..c6f64d671175
--- /dev/null
+++ b/duplicati.install
@@ -0,0 +1,63 @@
+post_install() {
+ mkdir -p /var/lib/duplicati
+ chown -R duplicati:duplicati /var/lib/duplicati
+
+ cat <<EOF
+ * UI can be accessed via following URL: http://localhost:8200
+ * Running duplicati user instance (using current user account)
+ - to start duplicati manually: systemctl --user start duplicati
+ - to autostart duplicati on user login: systemctl --user enable duplicati
+ *
+ * To run Duplicati.Server.exe as root, simply use systemd's "drop-in" feature
+ * and specify
+ * User=root
+ * Group=root
+
+EOF
+}
+
+post_upgrade() {
+ mkdir -p /var/lib/duplicati
+ chown -R duplicati:duplicati /var/lib/duplicati
+
+ if [ $(vercmp $2 2.0.2.10-1) -lt 0 ]; then
+ cat <<EOF
+ * In versions prior to 2.0.2.10-1, the system version of duplicati.service
+ * started Duplicati.Server.exe as root. It now runs as user duplicati.
+ * Please move your old duplicati database from
+ * /root/.config/Duplicati
+ * to
+ * /var/lib/duplicati/.config/Duplicati
+ * To run Duplicati.Server.exe as root, simply use systemd's "drop-in" feature
+ * and specify
+ * User=root
+ * Group=root
+EOF
+ fi
+
+ if [ $(vercmp $2 2.0.5.113-1) -lt 0 ]; then
+ cat <<EOF
+ * In versions 2.0.5.113 and above, the Telegram backend has been removed, and
+ * the SSH backend has increased its encryption algorithm requirements, which may
+ * break backups. See https://github.com/duplicati/duplicati/releases/tag/v2.0.5.113-2.0.5.113_canary_2021-03-07
+ * for details, and downgrade to an earlier version if necessary.
+
+EOF
+ if [ $(vercmp $2 2.0.6.104-5) -lt 0 ]; then
+ cat <<EOF
+ * This package was renamed from duplicati-latest to duplicati-canary-bin starting
+ * from 2.0.6.104-5. The install path was also changed from /opt/duplicati-latest to
+ * /opt/duplicati, so please update any scripts that referred to the installation
+ * directory directly.
+
+EOF
+ fi
+
+ cat <<EOF
+ * UI can be accessed via following URL: http://localhost:8200
+ * Running duplicati user instance (using current user account)
+ - to reload user systemd modules: systemctl --user daemon-reload
+ - to start duplicati manually: systemctl --user start duplicati
+ - to autostart duplicati on user login: systemctl --user enable duplicati
+EOF
+}
diff --git a/duplicati.service b/duplicati.service
new file mode 100644
index 000000000000..61c41e4f0c30
--- /dev/null
+++ b/duplicati.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Duplicati
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/mono /opt/duplicati/Duplicati.Server.exe --webservice-port=8200
+Restart=on-abort
+EnvironmentFile=-/etc/default/duplicati
+User=duplicati
+Group=duplicati
+
+[Install]
+WantedBy=default.target \ No newline at end of file
diff --git a/duplicati.sysusers b/duplicati.sysusers
new file mode 100644
index 000000000000..255522fde414
--- /dev/null
+++ b/duplicati.sysusers
@@ -0,0 +1 @@
+u duplicati - "Duplicati daemon" /var/lib/duplicati \ No newline at end of file
diff --git a/duplicati.tmpfiles.conf b/duplicati.tmpfiles.conf
new file mode 100644
index 000000000000..f5ca2b0d649c
--- /dev/null
+++ b/duplicati.tmpfiles.conf
@@ -0,0 +1 @@
+d /var/lib/duplicati 0755 duplicati duplicati -