summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2020-11-02 19:59:35 +0100
committerSebastian Wiesner2020-11-02 19:59:35 +0100
commit0da91b5f243f65357ef5ef94f9769d6aa40c9e95 (patch)
treef3cd42b1c12dd809cb7bebb61c1947967d4b097c
downloadaur-0da91b5f243f65357ef5ef94f9769d6aa40c9e95.tar.gz
Initial upload: duplicity-git rel.0.8.16.r29.15026d95-1
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53af7ad0f628
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = duplicity-git
+ pkgdesc = A utility for encrypted, bandwidth-efficient backups using the rsync algorithm.
+ pkgver = rel.0.8.16.r29.15026d95
+ pkgrel = 1
+ url = https://www.nongnu.org/duplicity/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = gnupg
+ depends = librsync
+ depends = python-paramiko
+ depends = python-fasteners
+ depends = python-future
+ optdepends = lftp: backend for ftp, ftps, fish
+ optdepends = ncftp: alternative backend for ftp
+ optdepends = python-boto: Amazon S3 and Google Cloud Storage backend
+ optdepends = python-dropbox: Dropbox backend
+ optdepends = python-gobject: GIO backend
+ optdepends = gvfs: GIO backend
+ optdepends = python-pydrive: Google Drive backend
+ optdepends = python-requests-oauthlib: OneDrive backend
+ optdepends = rsync: rsync backend
+ provides = duplicity
+ conflicts = duplicity
+ source = git+https://gitlab.com/duplicity/duplicity.git
+ md5sums = SKIP
+
+pkgname = duplicity-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a980af00afe5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc3c4da6921
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Aaron Schaefer <aaron@elasticdog.com>
+
+pkgname=duplicity-git
+pkgver=rel.0.8.16.r29.15026d95
+_pkgver=0.8.16
+pkgrel=1
+pkgdesc='A utility for encrypted, bandwidth-efficient backups using the rsync algorithm.'
+arch=('x86_64')
+url='https://www.nongnu.org/duplicity/'
+license=('GPL')
+depends=('gnupg' 'librsync' 'python-paramiko' 'python-fasteners' 'python-future')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+optdepends=('lftp: backend for ftp, ftps, fish'
+ 'ncftp: alternative backend for ftp'
+ 'python-boto: Amazon S3 and Google Cloud Storage backend'
+ 'python-dropbox: Dropbox backend'
+ 'python-gobject: GIO backend'
+ 'gvfs: GIO backend'
+ 'python-pydrive: Google Drive backend'
+ 'python-requests-oauthlib: OneDrive backend'
+ 'rsync: rsync backend')
+source=("git+https://gitlab.com/${pkgname%-git}/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}