summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Rosca2023-10-23 13:19:28 +0200
committerRobert Rosca2023-10-23 13:43:49 +0200
commit2582aef76bf5e29a7ccfbff9fe49fef3b9d4ba9d (patch)
tree26ca6f5076d701a6f2b01ac855115d5958ab9c4b
parenta1da55d442e6884b37571c4a097a02e6a5f9dbd1 (diff)
downloadaur-2582aef76bf5e29a7ccfbff9fe49fef3b9d4ba9d.tar.gz
clone source into `pkgname`, remove `_pkgname`
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a83f74dc6b7e..90d2e11cfc36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
pkgname=dura-git
-_pkgname=dura
pkgver=v0.2.0.r11.gb4a51b9
pkgrel=1
pkgdesc='Dura is a background process that watches your Git repositories and commits your uncommitted changes'
@@ -8,21 +7,20 @@ url=https://github.com/tkellogg/dura
license=(Apache)
makedepends=(git cargo)
provides=(dura)
-source=(git+$url)
+source=("${pkgname}::git+${url}")
sha512sums=('SKIP')
build() {
- cd $_pkgname
+ cd $pkgname
cargo build --locked --release
}
pkgver() {
- cd "$_pkgname"
+ cd "$pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd $_pkgname
+ cd $pkgname
install -D target/release/dura -t "$pkgdir"/usr/bin
}
-