summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFord Smith2022-01-03 23:09:53 -0500
committerFord Smith2022-01-03 23:14:53 -0500
commit2746b9392691bdd24032c63e1d11d4925fe9a75e (patch)
tree6fd5ae82197fc3f630bf759160ea6cf254933b63
downloadaur-2746b9392691bdd24032c63e1d11d4925fe9a75e.tar.gz
Initial Package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6741c4b3897c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dura-git
+ pkgdesc = Dura is a background process that watches your Git repositories and commits your uncommitted changes
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/tkellogg/dura
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = cargo
+ provides = dura
+ source = git+https://github.com/tkellogg/dura
+ sha512sums = SKIP
+
+pkgname = dura-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d9eec0a1376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=dura-git
+_pkgname=dura
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Dura is a background process that watches your Git repositories and commits your uncommitted changes'
+arch=(x86_64)
+url=https://github.com/tkellogg/dura
+license=(Apache)
+makedepends=(git cargo)
+provides=(dura)
+source=(git+$url)
+sha512sums=('SKIP')
+
+build() {
+ cd $_pkgname
+ cargo build --locked --release
+}
+
+package() {
+ cd $_pkgname
+ install -D target/release/dura -t "$pkgdir"/usr/bin
+}
+