summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkojq2024-03-29 14:33:27 -0400
committerkojq2024-03-29 14:33:27 -0400
commit6d911e057ca6fa8dd9101a54dc2174b346daf7db (patch)
treea6aef0893683066ceb21527b023a73d1ecd1907d
downloadaur-6d911e057ca6fa8dd9101a54dc2174b346daf7db.tar.gz
add PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d67c1273f57d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dust-emu-bin
+ pkgdesc = A Nintendo DS emulator written in Rust for desktop devices and the web, with debugging features and a focus on accuracy
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/kelpsyberry/dust
+ arch = x86_64
+ license = GPL-3.0
+ provides = dust-emu
+ conflicts = dust-emu
+ conflicts = dust-emu-git
+ source_x86_64 = https://nightly.link/kelpsyberry/dust/workflows/build-release/main/Linux.zip
+ sha256sums_x86_64 = 27dd5466573c35cba430afac3916f917aa62f376be2f4f380bfafcc85d41aed5
+
+pkgname = dust-emu-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9354a06eea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: kojq <kojq@mailfence.com>
+
+pkgname=dust-emu-bin
+_rel=-1
+pkgver=0
+pkgrel=1
+pkgdesc='A Nintendo DS emulator written in Rust for desktop devices and the web, with debugging features and a focus on accuracy'
+url=https://github.com/kelpsyberry/dust
+source_x86_64=(https://nightly.link/kelpsyberry/dust/workflows/build-release/main/Linux.zip)
+license=(GPL-3.0)
+arch=(x86_64)
+conflicts=(dust-emu dust-emu-git)
+provides=(dust-emu)
+sha256sums_x86_64=(27dd5466573c35cba430afac3916f917aa62f376be2f4f380bfafcc85d41aed5)
+
+prepare() {
+ cd $srcdir
+ tar -xf dust-desktop.tar.gz
+}
+
+package() {
+ cd $srcdir
+ install -Dm755 dust-desktop $pkgdir/usr/bin/dust-desktop
+}