summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2023-08-12 13:11:28 +0200
committerBlair Bonnett2023-08-12 13:11:28 +0200
commit0460c35bcf99b1e79938c5c0fd832ef9ef11ad73 (patch)
tree1464e760fc9601ea1bf4f7d6ffea036c6fe1dcea
parentb5306199cd7d8c270c391177543431f096cec353 (diff)
downloadaur-0460c35bcf99b1e79938c5c0fd832ef9ef11ad73.tar.gz
Update to 1.0.0-rc.9
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--cstdint.patch49
-rw-r--r--qt5.15_painterpath.patch9
4 files changed, 63 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 197ad1a49269..a44f0b9a89e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dust3d
pkgdesc = 3D watertight modeling software
- pkgver = 1.0.0rc.7
+ pkgver = 1.0.0rc.9
pkgrel = 1
url = https://dust3d.org/
arch = x86_64
@@ -10,9 +10,11 @@ pkgbase = dust3d
makedepends = qt5-tools
depends = qt5-base
depends = qt5-svg
- source = dust3d-1.0.0-rc.7.tar.gz::https://github.com/huxingyi/dust3d/archive/1.0.0-rc.7.tar.gz
+ source = dust3d-1.0.0-rc.9.tar.gz::https://github.com/huxingyi/dust3d/archive/1.0.0-rc.9.tar.gz
source = dust3d.desktop
- sha256sums = fa1b00d437f680eddf983fa46d29e2e223bfaef82c5c331d0cb672fa04ecccdb
+ source = cstdint.patch
+ sha256sums = 266c70166c96de550f504387cfe34c870ea2fbb376560511a38114e17836869b
sha256sums = f4742bc1a2795b435f8343f20516763522b8f710fefbb3e75ce7a02ea634a691
+ sha256sums = 1c3522dbd6e90cdda7c9572c35ed0f57a5c310e2dc0a2d8affafded9401b0612
pkgname = dust3d
diff --git a/PKGBUILD b/PKGBUILD
index a10b3ef9d008..1893cab507be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blair Bonnett <blair dot bonnett @ gmail dot com>
pkgname=dust3d
-_pkgver=1.0.0-rc.7
+_pkgver=1.0.0-rc.9
pkgver="${_pkgver//-/}"
pkgrel=1
pkgdesc="3D watertight modeling software"
@@ -14,12 +14,19 @@ arch=('x86_64')
source=(
"dust3d-$_pkgver.tar.gz::https://github.com/huxingyi/dust3d/archive/$_pkgver.tar.gz"
'dust3d.desktop'
+ 'cstdint.patch'
)
sha256sums=(
- 'fa1b00d437f680eddf983fa46d29e2e223bfaef82c5c331d0cb672fa04ecccdb'
+ '266c70166c96de550f504387cfe34c870ea2fbb376560511a38114e17836869b'
'f4742bc1a2795b435f8343f20516763522b8f710fefbb3e75ce7a02ea634a691'
+ '1c3522dbd6e90cdda7c9572c35ed0f57a5c310e2dc0a2d8affafded9401b0612'
)
+prepare() {
+ cd "$srcdir/dust3d-$_pkgver"
+ patch -p0 -i "$srcdir/cstdint.patch"
+}
+
build() {
cd "dust3d-$_pkgver/application"
qmake
diff --git a/cstdint.patch b/cstdint.patch
new file mode 100644
index 000000000000..0bbd526b1d58
--- /dev/null
+++ b/cstdint.patch
@@ -0,0 +1,49 @@
+--- application/third_party/fbx/src/fbxdocument.h
++++ application/third_party/fbx/src/fbxdocument.h
+
+@@ -2,7 +2,8 @@
+ #define FBXDOCUMENT_H
+
+ #include "fbxnode.h"
++#include <cstdint>
+
+ namespace fbx {
+
+ class FBXDocument
+
+--- application/third_party/fbx/src/fbxnode.h
++++ application/third_party/fbx/src/fbxnode.h
+
+@@ -2,7 +2,8 @@
+ #define FBXNODE_H
+
+ #include "fbxproperty.h"
++#include <cstdint>
+
+ namespace fbx {
+
+ class FBXNode
+
+--- dust3d/base/ds3_file.h
++++ dust3d/base/ds3_file.h
+
+@@ -23,6 +23,7 @@
+ #ifndef DUST3D_BASE_DS3_FILE_H_
+ #define DUST3D_BASE_DS3_FILE_H_
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+ #include <vector>
+
+--- dust3d/mesh/solid_mesh_boolean_operation.h
++++ dust3d/mesh/solid_mesh_boolean_operation.h
+
+@@ -26,6 +26,7 @@
+ #include <dust3d/base/position_key.h>
+ #include <dust3d/base/vector3.h>
+ #include <dust3d/mesh/solid_mesh.h>
++#include <cstdint>
+ #include <map>
+ #include <unordered_map>
+ #include <unordered_set>
diff --git a/qt5.15_painterpath.patch b/qt5.15_painterpath.patch
deleted file mode 100644
index 35f64635642a..000000000000
--- a/qt5.15_painterpath.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- src/contourtopartconverter.cpp 2020-06-06 16:48:21.826468585 +0200
-+++ src/contourtopartconverter.cpp 2020-06-06 16:49:24.381512126 +0200
-@@ -1,5 +1,6 @@
- #include <QImage>
- #include <QPainter>
-+#include <QPainterPath>
- #include <cmath>
- #include <QUuid>
- #include <cmath>