summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-11-13 12:39:29 +0100
committerFabioLolix2022-11-13 12:39:29 +0100
commitd91f159cbb41d7ff2f5da9c7ba7cfd7fadc73406 (patch)
tree4a716ed88c1d8ea842101d3eb544c327621ea8e9
parentb1bfc42b26ee0b013ba14c65dd0c741eed6c8925 (diff)
downloadaur-d91f159cbb41d7ff2f5da9c7ba7cfd7fadc73406.tar.gz
v8.4.1
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD15
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1db9e5505280..a8069042bacc 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = dvdae-bin
pkgdesc = DVD audio extract & ripping tool for extracting streams from DVD-Audio & Video discs and save them as OGG, MP3, Wave or FLAC files
- pkgver = 8.3.0
+ pkgver = 8.4.1
pkgrel = 1
url = https://www.dvdae.com/
arch = x86_64
- license = custom
- depends = flac
+ license = custom: Computer Application Studio EULA
+ makedepends = chrpath
+ depends = flac1.3
depends = gtk3
depends = lame
depends = libvorbis
depends = libsm
depends = alsa-lib
- source = https://www.dvdae.com/dvdae/dvdae_8.3.0_amd64.deb
+ source = https://www.dvdae.com/dvdae/dvdae_8.4.1_amd64.deb
source = https://www.dvdae.com/license.htm
- sha256sums = 0230ab1142a8a4c748c13c057a4650c544e4c2acb7996e249facdc406aac8e66
+ sha256sums = 8a8de84078471bd877460610d1f51bdb438f2f576c2f16f0b95dc155482346b2
sha256sums = 6d780e47d8c961a64fb12815872f2bf622018ff0623a9dd82abe59790cee0550
pkgname = dvdae-bin
diff --git a/PKGBUILD b/PKGBUILD
index dad253215890..46dd970c4b45 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,26 @@
# Contributor: Tristelune
pkgname=dvdae-bin
-pkgver=8.3.0
+pkgver=8.4.1
pkgrel=1
pkgdesc="DVD audio extract & ripping tool for extracting streams from DVD-Audio & Video discs and save them as OGG, MP3, Wave or FLAC files"
-url="https://www.dvdae.com/"
arch=(x86_64)
+url="https://www.dvdae.com/"
+license=('custom: Computer Application Studio EULA')
+depends=(flac1.3 gtk3 lame libvorbis libsm alsa-lib)
+makedepends=(chrpath)
source=("https://www.dvdae.com/dvdae/dvdae_${pkgver}_amd64.deb"
"https://www.dvdae.com/license.htm")
-license=('custom')
-depends=(flac gtk3 lame libvorbis libsm alsa-lib)
-sha256sums=('0230ab1142a8a4c748c13c057a4650c544e4c2acb7996e249facdc406aac8e66'
+sha256sums=('8a8de84078471bd877460610d1f51bdb438f2f576c2f16f0b95dc155482346b2'
'6d780e47d8c961a64fb12815872f2bf622018ff0623a9dd82abe59790cee0550')
package() {
cd "$srcdir"
bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}/
install -D -m644 license.htm "${pkgdir}/usr/share/licenses/${pkgname}/license.htm"
+
+ chrpath --delete "${pkgdir}/usr/bin/dvdae"
+ chrpath --delete "${pkgdir}/usr/bin/dvdae-gui"
chown root:root -vR "${pkgdir}/"
+ chmod 755 -vR "${pkgdir}/"
}