summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2022-03-07 14:08:50 -0500
committereshrh2022-03-07 14:08:50 -0500
commit7495c38b14f714ed1ccf42110b665b3ed7e800aa (patch)
treed5077e1162cfecdf3bf2d87ae078fcef76ce0d91
parent2d7f32e053829f76badb802c9ce985f19bb9cf4b (diff)
downloadaur-7495c38b14f714ed1ccf42110b665b3ed7e800aa.tar.gz
patch and correct install dir
-rw-r--r--.SRCINFO3
-rw-r--r--0001-sys_errlist-to-strerror.patch34
-rw-r--r--PKGBUILD20
3 files changed, 47 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6909703ab7bc..5a3a9145a73e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dvorak7min
pkgdesc = dvorak7min is a simple ncurses-based typing tutor for those trying to become fluent with the Dvorak keyboard layout
pkgver = 1.6.1
- pkgrel = 4
+ pkgrel = 5
url = http://packages.debian.org/unstable/games/dvorak7min
arch = i686
arch = x86_64
@@ -11,4 +11,3 @@ pkgbase = dvorak7min
md5sums = e2c3e02b4f0cf24fcf29118d01f52956
pkgname = dvorak7min
-
diff --git a/0001-sys_errlist-to-strerror.patch b/0001-sys_errlist-to-strerror.patch
new file mode 100644
index 000000000000..8276a0363d95
--- /dev/null
+++ b/0001-sys_errlist-to-strerror.patch
@@ -0,0 +1,34 @@
+From a74b7521f9de1b35a1505ac4dbaba4c3f21e3d6a Mon Sep 17 00:00:00 2001
+From: eshrh <esrh@gatech.edu>
+Date: Mon, 7 Mar 2022 13:28:57 -0500
+Subject: [PATCH] sys_errlist to strerror
+
+---
+ dvorak7min.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/dvorak7min.c b/dvorak7min.c
+index 5f94dfe..92b6a11 100644
+--- a/dvorak7min.c
++++ b/dvorak7min.c
+@@ -193,7 +193,7 @@ int importText (char const * const fileName, char** buf, unsigned int length)
+
+ file = fopen (fileName, "r");
+ if (!file) {
+- postmortem = sys_errlist[errno];
++ postmortem = strerror(errno);
+ return -1;
+ }
+
+@@ -220,7 +220,7 @@ int importText (char const * const fileName, char** buf, unsigned int length)
+ while (1) {
+ c = fgetc (file);
+ if (errno) {
+- postmortem = sys_errlist[errno];
++ postmortem = strerror(errno);
+ fclose (file);
+ return -1;
+ }
+--
+2.35.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 7f2af223150f..1f9944f10703 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,6 @@
-# Maintainer: Eric DeStefano <eric at ericdestefano dot com>
-# Contributor:Paul Bragg <paul2lv@gmail.com>
pkgname=dvorak7min
pkgver=1.6.1
-pkgrel=4
+pkgrel=5
pkgdesc="dvorak7min is a simple ncurses-based typing tutor for those trying to become fluent with the Dvorak keyboard layout"
arch=('i686' 'x86_64')
license=('GPL')
@@ -11,9 +9,15 @@ depends=('ncurses')
source=(http://http.debian.net/debian/pool/main/d/dvorak7min/dvorak7min_1.6.1+repack.orig.tar.gz)
md5sums=('e2c3e02b4f0cf24fcf29118d01f52956')
-package() {
- cd $startdir/src/$pkgname-$pkgver
- _installdir="$startdir/pkg/usr/bin"
- make INSTALL=$_installdir || return 1
- make INSTALL=$_installdir install || return 1
+
+build() {
+ cp $startdir/0001-sys_errlist-to-strerror.patch $pkgname-$pkgver
+ cd $pkgname-$pkgver
+ patch -p1 < 0001-sys_errlist-to-strerror.patch
+ make INSTALL="$pkgdir/usr/bin"
}
+
+package() {
+ cd $pkgname-$pkgver
+ make INSTALL="$pkgdir/usr/bin" install
+} \ No newline at end of file