summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-12-20 10:52:24 +0100
committerChristian Krause2015-12-20 10:52:24 +0100
commit0c3a01b602522f7024de06c63d46eb2dfe676c2c (patch)
treedd842590759b77c6baf5b8d7b1cadfb7dc3ca85e
downloadaur-0c3a01b602522f7024de06c63d46eb2dfe676c2c.tar.gz
initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD75
-rw-r--r--dwarffortress20
-rw-r--r--dwarffortress.desktop9
-rw-r--r--dwarffortress.install8
-rw-r--r--dwarffortress.pngbin0 -> 4647 bytes
6 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1be24567cc0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by mksrcinfo v8
+# Sun Dec 20 09:48:19 UTC 2015
+pkgbase = dwarffortress-ironhand
+ pkgdesc = A single-player fantasy game. You control a dwarven outpost or an adventurer in a randomly generated persistent world.
+ pkgver = 0.42.03
+ pkgrel = 1
+ url = http://www.bay12games.com/dwarves/
+ install = dwarffortress.install
+ arch = i686
+ arch = x86_64
+ license = custom:dwarffortress
+ makedepends = git
+ makedepends = cmake
+ depends = gtk2
+ depends = glu
+ depends = sdl_image
+ depends = libsndfile
+ depends = openal
+ depends = sdl_ttf
+ depends = glew
+ depends = gcc-libs
+ options = !strip
+ options = !buildflags
+ source = http://www.bay12games.com/dwarves/df_42_03_linux.tar.bz2
+ source = git://github.com/svenstaro/dwarf_fortress_unfuck.git#tag=0.42.03
+ source = dwarffortress
+ source = dwarffortress.desktop
+ source = dwarffortress.png
+ source = http://dffd.bay12games.com/download.php?id=11349&f=Ironhand_42_03A_Upgrade.zip
+ sha256sums = 6bc36b3562da0a8d6e1f14d269e2a4ce04b8f2f6ffc516b542bc7ac8ae50b3cc
+ sha256sums = SKIP
+ sha256sums = 7dc1f0ed0d496b21f4f240334f77dc43b728823f3e1c4ea25ce768691346ec07
+ sha256sums = 0c279596f88b5fca4e0676627bfc6739b5da9416cc099abf5865ee6c0fd13435
+ sha256sums = 83183abc70b11944720b0d86f4efd07468f786b03fa52fe429ca8e371f708e0f
+ sha256sums = 17b8209d90cfffc8bcae9ac69fe5c302cbd38016012a6af1841269be6972a70b
+
+pkgname = dwarffortress-ironhand
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40514a820f5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=dwarffortress-ironhand
+pkgver=0.42.03
+_pkgver=42_03
+pkgrel=1
+pkgdesc="A single-player fantasy game. You control a dwarven outpost or an adventurer in a randomly generated persistent world."
+arch=(i686 x86_64)
+url="http://www.bay12games.com/dwarves/"
+license=('custom:dwarffortress')
+depends=(gtk2 glu sdl_image libsndfile openal sdl_ttf glew gcc-libs)
+makedepends=(git cmake)
+options=('!strip' '!buildflags')
+install=dwarffortress.install
+if [[ $CARCH == 'x86_64' ]]; then
+ makedepends+=(gcc-multilib)
+ depends=(gcc-libs-multilib lib32-gtk2 lib32-glu lib32-sdl_image lib32-libsndfile lib32-openal
+ lib32-libxdamage lib32-ncurses lib32-sdl_ttf lib32-glew)
+ optdepends=('lib32-nvidia-utils: If you have nvidia graphics'
+ 'lib32-catalyst-utils: If you have ATI graphics'
+ 'lib32-alsa-lib: for alsa sound'
+ 'lib32-libpulse: for pulse sound')
+fi
+# I made a fucking github repo with the sole purpose of unfucking df a bit
+# We try to compile whatever little bit of df is open source
+source=(http://www.bay12games.com/dwarves/df_${_pkgver}_linux.tar.bz2
+ git://github.com/svenstaro/dwarf_fortress_unfuck.git#tag=${pkgver}
+ dwarffortress
+ dwarffortress.desktop
+ dwarffortress.png
+ 'http://dffd.bay12games.com/download.php?id=11349&f=Ironhand_42_03A_Upgrade.zip')
+sha256sums=('6bc36b3562da0a8d6e1f14d269e2a4ce04b8f2f6ffc516b542bc7ac8ae50b3cc'
+ 'SKIP'
+ '7dc1f0ed0d496b21f4f240334f77dc43b728823f3e1c4ea25ce768691346ec07'
+ '0c279596f88b5fca4e0676627bfc6739b5da9416cc099abf5865ee6c0fd13435'
+ '83183abc70b11944720b0d86f4efd07468f786b03fa52fe429ca8e371f708e0f'
+ '17b8209d90cfffc8bcae9ac69fe5c302cbd38016012a6af1841269be6972a70b')
+
+build() {
+ cd $srcdir/dwarf_fortress_unfuck
+
+ cmake .
+ make
+}
+
+package() {
+ install -dm755 $pkgdir/opt/
+ cp -r $srcdir/df_linux $pkgdir/opt/$pkgname
+ rm -r $pkgdir/opt/$pkgname/df $pkgdir/opt/$pkgname/libs/* $pkgdir/opt/$pkgname/g_src
+
+ cp -r $srcdir/"Dwarf Fortress"/* $pkgdir/opt/$pkgname
+
+ find $pkgdir/opt/$pkgname -type d -exec chmod 755 {} +
+ find $pkgdir/opt/$pkgname -type f -exec chmod 644 {} +
+
+ install -Dm755 $srcdir/df_linux/libs/Dwarf_Fortress $pkgdir/opt/$pkgname/libs/Dwarf_Fortress
+ install -Dm755 $srcdir/dwarf_fortress_unfuck/libgraphics.so $pkgdir/opt/$pkgname/libs/libgraphics.so
+ install -Dm755 $srcdir/dwarffortress $pkgdir/usr/bin/$pkgname
+
+ # No idea why we need this. Really. This isn't being loaded dynamically, it's not linked and
+ # in general there is no indication this is being used. However, it doesn't work without this symlink.
+ [[ $CARCH == "x86_64" ]] && ln -s /usr/lib32/libpng.so $pkgdir/opt/$pkgname/libs/libpng.so.3
+ [[ $CARCH == "i686" ]] && ln -s /usr/lib/libpng.so $pkgdir/opt/$pkgname/libs/libpng.so.3
+
+ # Set pkgname in runscript
+ sed -i "s/^pkgname=.*/pkgname=$pkgname/" $pkgdir/usr/bin/$pkgname
+
+ # Desktop launcher with icon
+ install -Dm644 $srcdir/dwarffortress.desktop $pkgdir/usr/share/applications/"$pkgname".desktop
+ install -Dm644 $srcdir/dwarffortress.png $pkgdir/usr/share/pixmaps/"$pkgname".png
+
+ install -Dm644 $srcdir/df_linux/readme.txt $pkgdir/usr/share/licenses/$pkgname/readme.txt
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dwarffortress b/dwarffortress
new file mode 100644
index 000000000000..176e1b3a9f66
--- /dev/null
+++ b/dwarffortress
@@ -0,0 +1,20 @@
+#!/bin/sh
+export SDL_DISABLE_LOCK_KEYS=1 # Work around for bug in Debian/Ubuntu SDL patch.
+#export SDL_VIDEO_CENTERED=1 # Centre the screen. Messes up resizing.
+
+pkgname=dwarffortress #To be set by PKGBUILD
+
+if [[ ! -d "$HOME/.$pkgname" ]]; then
+ mkdir -p "$HOME/.$pkgname/data"
+ ln -s /opt/"$pkgname"/raw "$HOME/.$pkgname/raw"
+ ln -s /opt/"$pkgname"/libs "$HOME/.$pkgname/libs"
+ cp -rn /opt/"$pkgname"/data/init "$HOME/.$pkgname/data/init"
+fi
+
+for link in announcement art dipscript help index initial_movies movies shader.fs shader.vs sound speech; do
+ cp -r /opt/"$pkgname"/data/$link "$HOME/.$pkgname/data/$link"
+done
+
+cd "$HOME/.$pkgname"
+exec ./libs/Dwarf_Fortress "$@"
+
diff --git a/dwarffortress.desktop b/dwarffortress.desktop
new file mode 100644
index 000000000000..fc2115788410
--- /dev/null
+++ b/dwarffortress.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Dwarf Fortress Ironhand
+GenericName=Dwarf Fortress Ironhand
+Comment=A single-player fantasy game.
+Exec=dwarffortress-ironhand
+Icon=/usr/share/pixmaps/dwarffortress-ironhand.png
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/dwarffortress.install b/dwarffortress.install
new file mode 100644
index 000000000000..299e76d383c1
--- /dev/null
+++ b/dwarffortress.install
@@ -0,0 +1,8 @@
+post_upgrade() {
+ echo "You might have delete your ~/.dwarffortress directory to get the new file layout."
+ echo "Of course, you can backup your saves."
+}
+
+post_install() {
+ post_upgrade
+}
diff --git a/dwarffortress.png b/dwarffortress.png
new file mode 100644
index 000000000000..97c864f100dd
--- /dev/null
+++ b/dwarffortress.png
Binary files differ