summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel Stickney2018-03-31 15:08:34 +0200
committerChristian Krause2018-03-31 15:08:34 +0200
commit58fa1ec0c444fb83c8d781a4243887e55b85e96d (patch)
treed5f5cfd2dd982a3cbc81a4c349dedf46f4db0f49
parenta41fa47a80c41586043eafa8ff6eae03eb9e21f6 (diff)
downloadaur-58fa1ec0c444fb83c8d781a4243887e55b85e96d.tar.gz
dwarffortress-ironhand-0.44.07-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD49
2 files changed, 29 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03778d2aa352..3aec96ac7296 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Mar 15 18:47:48 UTC 2018
pkgbase = dwarffortress-ironhand
pkgdesc = A single-player fantasy game in which you build a dwarven outpost or play an adventurer in a randomly generated world
pkgver = 0.44.07
- pkgrel = 1
+ pkgrel = 2
url = http://www.bay12games.com/dwarves/
install = dwarffortress.install
arch = x86_64
@@ -28,12 +26,12 @@ pkgbase = dwarffortress-ironhand
conflicts = dwarffortress-obsidian
options = !strip
options = !buildflags
- source = git://github.com/svenstaro/dwarf_fortress_unfuck.git#tag=0.44.07
+ source = dwarffortress-unfuck-0.44.07.tar.gz::https://github.com/svenstaro/dwarf_fortress_unfuck/archive/0.44.07.tar.gz
source = dwarffortress
source = dwarffortress.desktop
source = ironhand-44.07.tar.gz::https://github.com/DFgraphics/Ironhand/archive/44.07.tar.gz
source = dwarffortress.png
- sha256sums = SKIP
+ sha256sums = 8660a9347f86e063606d8d6cd0d5cfd8a6b88d024c4a902b3dcabbde08c9faf8
sha256sums = 211eaec6559d4fd5c08341dbed1f27bfab997a57bdf61fd268f9940e244652c5
sha256sums = e79e3d945c6cc0da58f4ca30a210c7bf1bc3149fd10406d1262a6214eb40445a
sha256sums = 51f842626e8af972c260d8ba8b33f1ce60f9d3871c2cf807a0285aeec4ae6c1d
diff --git a/PKGBUILD b/PKGBUILD
index c73c0e5a595b..fe2eacc7185e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,13 @@
# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
+# Contributor: Nathaniel Stickney <nstickney@gmail.com>
+# shellcheck disable=2034
+# shellcheck disable=2148
pkgname=dwarffortress-ironhand
_pkgname=dwarffortress
pkgver=0.44.07
_pkgver=44_07
-pkgrel=1
+pkgrel=2
tilesetver=44.07
pkgdesc="A single-player fantasy game in which you build a dwarven outpost or play an adventurer in a randomly generated world"
arch=('x86_64' 'i686')
@@ -19,14 +22,14 @@ options=('!strip' '!buildflags')
install=${_pkgname}.install
# I made a fucking github repo with the sole purpose of unfucking df a bit
# We try to compile whatever little bit of df is open source
-source=(git://github.com/svenstaro/dwarf_fortress_unfuck.git#tag=${pkgver}
+source=("dwarffortress-unfuck-$pkgver.tar.gz::https://github.com/svenstaro/dwarf_fortress_unfuck/archive/$pkgver.tar.gz"
dwarffortress
dwarffortress.desktop
"ironhand-${tilesetver}.tar.gz::https://github.com/DFgraphics/Ironhand/archive/${tilesetver}.tar.gz"
dwarffortress.png)
-source_x86_64=(http://www.bay12games.com/dwarves/df_${_pkgver}_linux.tar.bz2)
-source_i686=(http://www.bay12games.com/dwarves/df_${_pkgver}_linux32.tar.bz2)
-sha256sums=('SKIP'
+source_x86_64=(http://www.bay12games.com/dwarves/df_"${_pkgver}"_linux.tar.bz2)
+source_i686=(http://www.bay12games.com/dwarves/df_"${_pkgver}"_linux32.tar.bz2)
+sha256sums=('8660a9347f86e063606d8d6cd0d5cfd8a6b88d024c4a902b3dcabbde08c9faf8'
'211eaec6559d4fd5c08341dbed1f27bfab997a57bdf61fd268f9940e244652c5'
'e79e3d945c6cc0da58f4ca30a210c7bf1bc3149fd10406d1262a6214eb40445a'
'51f842626e8af972c260d8ba8b33f1ce60f9d3871c2cf807a0285aeec4ae6c1d'
@@ -35,41 +38,41 @@ sha256sums_x86_64=('2b41550b486ebfdb7972f730607f7ed9e192c9b31633454606134eb2e57f
sha256sums_i686=('347736edcd10a2506a29ea2acadaa27c2ad019f13f453830f141006d8ea72806')
conflicts=(dwarffortress dwarffortress-obsidian)
-provides=(dwarffortress=$pkgver)
+provides=("dwarffortress=$pkgver")
build() {
- cd $srcdir/dwarf_fortress_unfuck
-
+ # shellcheck disable=2154
+ cd "$srcdir"/dwarf_fortress_unfuck-"$pkgver" || exit
cmake .
make
}
package() {
- install -dm755 $pkgdir/opt/
- cp -r $srcdir/df_linux $pkgdir/opt/$_pkgname
- rm -r $pkgdir/opt/$_pkgname/df $pkgdir/opt/$_pkgname/libs/* $pkgdir/opt/$_pkgname/g_src
+ # shellcheck disable=2154
+ install -dm755 "$pkgdir"/opt/
+ cp -r "$srcdir"/df_linux "$pkgdir"/opt/"$_pkgname"
+ rm -r "$pkgdir"/opt/"$_pkgname"/df "$pkgdir"/opt/"$_pkgname"/libs/* "$pkgdir"/opt/"$_pkgname"/g_src
- cp -r $srcdir/Ironhand-$tilesetver/* $pkgdir/opt/$_pkgname
+ cp -r "$srcdir"/Ironhand-"$tilesetver"/* "$pkgdir"/opt/"$_pkgname"
- find $pkgdir/opt/$_pkgname -type d -exec chmod 755 {} +
- find $pkgdir/opt/$_pkgname -type f -exec chmod 644 {} +
+ find "$pkgdir"/opt/"$_pkgname" -type d -exec chmod 755 {} +
+ find "$pkgdir"/opt/"$_pkgname" -type f -exec chmod 644 {} +
- install -Dm755 $srcdir/df_linux/libs/Dwarf_Fortress $pkgdir/opt/$_pkgname/libs/Dwarf_Fortress
- install -Dm755 $srcdir/dwarf_fortress_unfuck/libgraphics.so $pkgdir/opt/$_pkgname/libs/libgraphics.so
- install -Dm755 $srcdir/dwarffortress $pkgdir/usr/bin/$_pkgname
+ install -Dm755 "$srcdir"/df_linux/libs/Dwarf_Fortress "$pkgdir"/opt/"$_pkgname"/libs/Dwarf_Fortress
+ install -Dm755 "$srcdir"/dwarf_fortress_unfuck-"$pkgver"/libgraphics.so "$pkgdir"/opt/"$_pkgname"/libs/libgraphics.so
+ install -Dm755 "$srcdir"/dwarffortress "$pkgdir"/usr/bin/"$_pkgname"
# No idea why we need this. Really. This isn't being loaded dynamically, it's not linked and
# in general there is no indication this is being used. However, it doesn't work without this symlink.
- ln -s /usr/lib/libpng.so $pkgdir/opt/$_pkgname/libs/libpng.so.3
+ ln -s /usr/lib/libpng.so "$pkgdir"/opt/"$_pkgname"/libs/libpng.so.3
# Set pkgname in runscript
- sed -i "s/^pkgname=.*/pkgname=$_pkgname/" $pkgdir/usr/bin/$_pkgname
+ sed -i "s/^pkgname=.*/pkgname=$_pkgname/" "$pkgdir"/usr/bin/"$_pkgname"
# Desktop launcher with icon
- install -Dm644 $srcdir/dwarffortress.desktop $pkgdir/usr/share/applications/"$_pkgname".desktop
- install -Dm644 $srcdir/dwarffortress.png $pkgdir/usr/share/pixmaps/"$_pkgname".png
-
- install -Dm644 $srcdir/df_linux/readme.txt $pkgdir/usr/share/licenses/$pkgname/readme.txt
+ install -Dm644 "$srcdir"/dwarffortress.desktop "$pkgdir"/usr/share/applications/"$_pkgname".desktop
+ install -Dm644 "$srcdir"/dwarffortress.png "$pkgdir"/usr/share/pixmaps/"$_pkgname".png
+ install -Dm644 "$srcdir"/df_linux/readme.txt "$pkgdir"/usr/share/licenses/"$pkgname"/readme.txt
}
# vim:set ts=2 sw=2 et: