summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2022-03-04 15:57:14 -0500
committerStick2022-03-04 15:57:14 -0500
commitfd49751fb2ed609b8f83f1be52f34e60947fa71c (patch)
treeac14fd882ea3da24f6eb240738fecb1343aae038
parent6eb962a30e3e94c3854ed85aceedc9cb7e749a56 (diff)
downloadaur-fd49751fb2ed609b8f83f1be52f34e60947fa71c.tar.gz
match deps to official dwarffortress package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b607c31b329..bfbba69e0590 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dwarffortress-ironhand
pkgdesc = A single-player fantasy game in which you build a dwarven outpost or play an adventurer in a randomly generated world
pkgver = 0.47.05
- pkgrel = 1
+ pkgrel = 2
url = http://www.bay12games.com/dwarves/
install = dwarffortress.install
arch = x86_64
@@ -9,18 +9,19 @@ pkgbase = dwarffortress-ironhand
license = custom:dwarffortress
makedepends = git
makedepends = cmake
- depends = gtk2
+ depends = gcc-libs
+ depends = glew
+ depends = glib2
depends = glu
- depends = sdl_image
+ depends = gtk3
depends = libsndfile
depends = openal
+ depends = sdl
+ depends = sdl_image
depends = sdl_ttf
- depends = glew
- depends = gcc-libs
- depends = glib2
- optdepends = nvidia-utils: If you have nvidia graphics
optdepends = alsa-lib: for alsa sound
optdepends = libpulse: for pulse sound
+ optdepends = nvidia-utils: If you have nvidia graphics
provides = dwarffortress=0.47.05
conflicts = dwarffortress
conflicts = dwarffortress-obsidian
diff --git a/PKGBUILD b/PKGBUILD
index bfd25253044e..d65b761cd95c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,18 @@ pkgname=dwarffortress-ironhand
_pkgname=dwarffortress
_pkgver=47_05
pkgver="0.${_pkgver/_/.}"
-pkgrel=1
+pkgrel=2
pkgdesc="A single-player fantasy game in which you build a dwarven outpost or play an adventurer in a randomly generated world"
arch=('x86_64' 'i686')
url="http://www.bay12games.com/dwarves/"
license=('custom:dwarffortress')
-depends=(gtk2 glu sdl_image libsndfile openal sdl_ttf glew gcc-libs glib2)
+depends=(gcc-libs glew glib2 glu gtk3 libsndfile openal sdl sdl_image sdl_ttf)
makedepends=(git cmake)
-optdepends=('nvidia-utils: If you have nvidia graphics'
+optdepends=(
'alsa-lib: for alsa sound'
- 'libpulse: for pulse sound')
+ 'libpulse: for pulse sound'
+ 'nvidia-utils: If you have nvidia graphics'
+)
options=('!strip' '!buildflags')
install=${_pkgname}.install
# I made a fucking github repo with the sole purpose of unfucking df a bit