aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetamer2016-07-14 23:37:25 -0700
committermetamer2016-07-15 20:11:16 -0700
commit963e03060eac928c1ab0c632de16438ff1002eae (patch)
treeaef825e6038ef1e846e196a4a6b24329c0bf58be
parent407e2a5fc02d96eaa60ef9f6c4da82255d289485 (diff)
downloadaur-963e03060eac928c1ab0c632de16438ff1002eae.tar.gz
update to 43.03
patch for terminal in pylnp checksum update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--pylnp-terminal.patch11
3 files changed, 30 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a10c84044ac3..fb6cd7451f7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dwarffortress-lnp-git
pkgdesc = Installer for the Lazy Newb Pack to run Dwarf Fortress. Includes vanilla dwarf fortress, dfhack and graphics
- pkgver = 42.06
+ pkgver = 43.03
pkgrel = 1
epoch = 0
install = dwarffortress-lnp-git.install
@@ -45,12 +45,13 @@ pkgbase = dwarffortress-lnp-git
options = !buildflags
source = git+https://github.com/Lazy-Newb-Pack/Lazy-Newb-Pack-Linux
source = git+https://github.com/DFgraphics/DFgraphics.git
- source = git+https://github.com/DFHack/dfhack.git#tag=0.42.06-beta1
- source = git+https://github.com/svenstaro/dwarf_fortress_unfuck.git
+ source = git+https://github.com/DFHack/dfhack.git#tag=0.43.03-r1
+ source = git+https://github.com/svenstaro/dwarf_fortress_unfuck.git#tag=0.43.03
source = git+https://github.com/mifki/df-twbt.git
source = hg+https://bitbucket.org/Pidgeot/python-lnp
- source = http://bay12games.com/dwarves/df_42_06_linux.tar.bz2
+ source = http://bay12games.com/dwarves/df_43_03_linux.tar.bz2
source = DFAnnouncementFilter.zip::http://dffd.bay12games.com/download.php?id=7905&f=DFAnnouncementFilter.zip
+ source = pylnp-terminal.patch
source = dfhack-twbt.patch
source = dfhack-visualizers.patch
source = lnp
@@ -62,8 +63,9 @@ pkgbase = dwarffortress-lnp-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 47f5a2ea1c4de2b742b50dd876b73feb
+ md5sums = 17d9ceb486fd476b4c6e8f0834d21d2e
md5sums = affd6273731c321d364c55a8da314fea
+ md5sums = 35e4942313f50d35e58e9c2a51874a82
md5sums = 856c54681faed3608cd951bf286d12d5
md5sums = 5cc79b5dc202d8faa02086293badfcee
md5sums = 389e34b6937f843c8f635d5e7326c9fc
diff --git a/PKGBUILD b/PKGBUILD
index ef6ba561bd90..6b9d1c6c8a5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname=dwarffortress-lnp-git
-pkgver=42.06
-_pkgver=42_06
-_dfhack_pkgrel=beta1
+pkgver=43.03
+_pkgver=43_03
+_dfhack_pkgrel=r1
pkgrel=1
epoch=0
pkgdesc="Installer for the Lazy Newb Pack to run Dwarf Fortress. Includes vanilla dwarf fortress, dfhack and graphics"
@@ -40,11 +40,12 @@ changelog=
source=(git+"https://github.com/Lazy-Newb-Pack/Lazy-Newb-Pack-Linux"
git+"https://github.com/DFgraphics/DFgraphics.git"
git+"https://github.com/DFHack/dfhack.git"#"tag=0.${pkgver}-${_dfhack_pkgrel}"
- git+"https://github.com/svenstaro/dwarf_fortress_unfuck.git"
+ git+"https://github.com/svenstaro/dwarf_fortress_unfuck.git"#"tag=0.${pkgver}"
git+"https://github.com/mifki/df-twbt.git"
hg+"https://bitbucket.org/Pidgeot/python-lnp"
"http://bay12games.com/dwarves/df_${_pkgver}_linux.tar.bz2"
"DFAnnouncementFilter.zip"::"http://dffd.bay12games.com/download.php?id=7905&f=DFAnnouncementFilter.zip"
+ "pylnp-terminal.patch"
"dfhack-twbt.patch"
"dfhack-visualizers.patch"
"lnp"
@@ -60,8 +61,9 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '47f5a2ea1c4de2b742b50dd876b73feb'
+ '17d9ceb486fd476b4c6e8f0834d21d2e'
'affd6273731c321d364c55a8da314fea'
+ '35e4942313f50d35e58e9c2a51874a82'
'856c54681faed3608cd951bf286d12d5'
'5cc79b5dc202d8faa02086293badfcee'
'389e34b6937f843c8f635d5e7326c9fc'
@@ -114,10 +116,13 @@ prepare() {
-DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
-DCMAKE_SHARED_LINKER_FLAGS:STRING="${LDFLAGS}"
+ cd $srcdir/python-lnp/core
+ patch -uN terminal.py $srcdir/pylnp-terminal.patch
+
}
build() {
- export DFHACKVER="${pkgver}-r5"
+ export DFHACKVER="${pkgver}-r3"
cd $srcdir/dwarf_fortress_unfuck
cd build
@@ -232,8 +237,7 @@ package() {
for license in python-lnp/COPYING.txt dfhack/depends/protobuf/COPYING.txt \
dfhack/plugins/stonesense/LICENSE dfhack/LICENSE.rst \
- dfhack/depends/lua/COPYRIGHT dfhack/scripts/3rdparty/maienm/LICENSE \
- dfhack/scripts/3rdparty/lethosor/LICENSE ; do
+ ; do
install -DTm644 "$srcdir/$license" \
"${pkgdir}/usr/share/licenses/${pkgname}/$license"
done
diff --git a/pylnp-terminal.patch b/pylnp-terminal.patch
new file mode 100644
index 000000000000..455abfc3e5dc
--- /dev/null
+++ b/pylnp-terminal.patch
@@ -0,0 +1,11 @@
+--- terminal.py.old 2016-07-15 18:56:06.339216999 -0700
++++ terminal.py 2016-07-15 18:56:26.132648665 -0700
+@@ -28,7 +28,7 @@
+ c.append(s)
+ return c
+ else:
+- return term + cmd
++ return term + [cmd]
+ raise Exception('No terminal launcher for platform: ' + sys.platform)
+
+ def get_configured_terminal():