summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-12-27 14:03:53 +0800
committerjustforlxz2022-12-27 14:03:53 +0800
commit5b8d888ec8b0678a51e966808a45780e8896928f (patch)
tree3cdd37c21b84b8f2bb41db6db2dc507e0410588c
downloadaur-5b8d888ec8b0678a51e966808a45780e8896928f.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f82db24458fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dwayland-git
+ pkgdesc = Qt-style Client and Server library wrapper for the Wayland libraries
+ pkgver = 5.24.3.deepin.1.4.r0.g3e2d16d
+ pkgrel = 1
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = doxygen
+ makedepends = qt5-tools
+ makedepends = qt5-doc
+ makedepends = wayland-protocols
+ makedepends = deepin-wayland-protocols-git
+ makedepends = ninja
+ depends = qt5-wayland
+ options = debug
+ source = dwayland-git::git+https://github.com/justforlxz/dwayland
+ sha256sums = SKIP
+
+pkgname = dwayland-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdbc0eb64098
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=dwayland-git
+pkgver=5.24.3.deepin.1.4.r0.g3e2d16d
+pkgrel=1
+pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries'
+arch=(x86_64)
+license=(LGPL)
+depends=(qt5-wayland)
+makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc wayland-protocols deepin-wayland-protocols-git ninja)
+source=("$pkgname::git+https://github.com/justforlxz/dwayland")
+sha256sums=('SKIP')
+options=(debug)
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -G Ninja -B build -S $pkgname \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+