summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-11-16 17:20:55 +0800
committerjustforlxz2022-11-16 17:21:34 +0800
commitf99eb070896b91237ecc6c0597dd3c3cf101f9f3 (patch)
tree1ab346db8f66ec0918eb201a2c3912cd34391754
downloadaur-f99eb070896b91237ecc6c0597dd3c3cf101f9f3.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d2bd9cca8af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dwayland-reborn
+ pkgdesc = Qt-style Client and Server library wrapper for the Wayland libraries
+ pkgver = 5.24.3
+ pkgrel = 1
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = doxygen
+ makedepends = qt5-tools
+ makedepends = qt5-doc
+ makedepends = wayland-protocols
+ makedepends = deepin-wayland-protocols-reborn
+ depends = qt5-wayland
+ options = debug
+ source = https://github.com/justforlxz/dwayland/archive/refs/tags/5.24.3-deepin.1.3.tar.gz
+ sha256sums = 898e0679fdcbb9c5b7276b1e39f823437f26234b57dcdab0126d18caca9af079
+
+pkgname = dwayland-reborn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebb11bf564e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=dwayland-reborn
+_pkgname=dwayland
+pkgver=5.24.3
+_tag=5.24.3-deepin.1.3
+pkgrel=1
+pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries'
+arch=(x86_64)
+license=(LGPL)
+depends=(qt5-wayland)
+makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc wayland-protocols deepin-wayland-protocols-reborn)
+source=(https://github.com/justforlxz/dwayland/archive/refs/tags/$_tag.tar.gz)
+sha256sums=('898e0679fdcbb9c5b7276b1e39f823437f26234b57dcdab0126d18caca9af079')
+options=(debug)
+
+build() {
+ cmake -B build -S $_pkgname-$_tag \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}