summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-03-23 07:23:48 +0100
committeraksr2016-03-23 07:23:48 +0100
commit4024ac1ec72e01799c29f040de9951326b5408e1 (patch)
tree2a942239ed637212f1720ac334de13a959613be4
downloadaur-4024ac1ec72e01799c29f040de9951326b5408e1.tar.gz
Start.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD55
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0a2750e96c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Mar 23 06:23:48 UTC 2016
+pkgbase = dwb-belllabs-git
+ pkgdesc = A fork of the original Documenter's Workbench Release 3.3.
+ pkgver = 20150517.r10.gd77e740
+ pkgrel = 1
+ url = https://github.com/n-t-roff/DWB3.3
+ arch = i686
+ arch = x86_64
+ license = EPL
+ makedepends = git
+ conflicts = dwb-belllabs
+ source = dwb-belllabs-git::git+https://github.com/n-t-roff/DWB3.3.git
+ md5sums = SKIP
+
+pkgname = dwb-belllabs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7f98540b38e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=dwb-belllabs-git
+pkgver=20150517.r10.gd77e740
+pkgrel=1
+epoch=
+pkgdesc="A fork of the original Documenter's Workbench Release 3.3."
+arch=('i686' 'x86_64')
+url="https://github.com/n-t-roff/DWB3.3"
+license=('EPL')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('dwb-belllabs')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/n-t-roff/DWB3.3.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make -f dwb.mk
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ _prefix="opt/" # "usr/" changed to "opt/" to avoid conflicts
+ make -f dwb.mk ROOT="$pkgdir/" \
+ BINDIR="$pkgdir/$_prefix/dwb/bin" \
+ FONTDIR="$pkgdir/$_prefix/dwb/lib/font" \
+ HOSTDIR="$pkgdir/$_prefix/dwb/lib/font/postscript" \
+ POSTLIB="$pkgdir/$_prefix/dwb/lib/postscript" \
+ LIBDIR="$pkgdir/$_prefix/dwb/lib/dwb" \
+ MACRODIR="$pkgdir/$_prefix/dwb/lib/macros" \
+ MAN1DIR="$pkgdir/$_prefix/dwb/man/man1" \
+ MAN5DIR="$pkgdir/$_prefix/dwb/man/man5" \
+ NTERMDIR="$pkgdir/$_prefix/dwb/lib/nterm" \
+ POSTBIN="$pkgdir/$_prefix/dwb/bin/postscript" \
+ POSTLIB="$pkgdir/$_prefix/dwb/lib/postscript" \
+ PUBDIR="$pkgdir/$_prefix/dwb/pub" \
+ RASTDIR="$pkgdir/$_prefix/dwb/lib/raster" \
+ TMACDIR="$pkgdir/$_prefix/dwb/lib/tmac" install
+}
+