summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-03-15 17:39:14 -0700
committerclintval2018-03-15 17:39:14 -0700
commit918ad207cd356fa9e3a43899e823f87bc0b5d1a8 (patch)
treed13934f73cc253490b4a9dfd3e6ac1b9687add32
downloadaur-918ad207cd356fa9e3a43899e823f87bc0b5d1a8.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d791c9d7d5cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dwgsim-git
+ pkgdesc = Whole genome read simulator for Next-Generation Sequencing data
+ pkgver = r159.39a1bbb
+ pkgrel = 1
+ url = https://github.com/lh3/dwgsim
+ arch = x86_64
+ license = GPL2
+ source = dwgsim::git+https://github.com/nh13/DWGSIM.git
+ sha256sums = SKIP
+
+pkgname = dwgsim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e6668d7a970
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=dwgsim
+pkgname="${_name}"-git
+pkgver=r159.39a1bbb
+pkgrel=1
+pkgdesc="Whole genome read simulator for Next-Generation Sequencing data"
+arch=('x86_64')
+url=https://github.com/lh3/"${_name}"
+license=('GPL2')
+source=('dwgsim::git+https://github.com/nh13/DWGSIM.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/"${_name}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}"/"${_name}"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "${srcdir}"/"${_name}"
+ make
+}
+
+package() {
+ cd "${srcdir}"/"${_name}"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/doc/"${_name}"/LICENSE
+ install -Dm755 "${_name}" "${pkgdir}"/usr/sbin/"${_name}"
+}