summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2017-07-21 20:53:47 +0200
committerUffe Jakobsen2017-07-21 20:53:47 +0200
commit13dcf66468cbd8ad2c5a983189dcf8c3d93fd860 (patch)
tree7ebefda18fe1750438025245d3b2703888b5a191
downloadaur-13dcf66468cbd8ad2c5a983189dcf8c3d93fd860.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eaf1704af7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jul 21 18:52:54 UTC 2017
+pkgbase = dwire-debug-git
+ pkgdesc = Simple stand-alone debugger for ATtiny 45 and ATMEL AVR DebugWIRE chips connected directly to an FT232R or similar
+ pkgver = r129.beb3806
+ pkgrel = 1
+ url = https://github.com/dcwbrown/dwire-debug
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gtk3
+ source = git+https://github.com/dcwbrown/dwire-debug.git
+ md5sums = SKIP
+
+pkgname = dwire-debug-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e54e630c6571
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+#
+# Maintainer: Uffe Jakobsen <uffe@uffe.org>
+#
+
+pkgname=dwire-debug-git
+_pkgname=dwire-debug
+pkgver=r129.beb3806
+pkgrel=1
+pkgdesc="Simple stand-alone debugger for ATtiny 45 and ATMEL AVR DebugWIRE chips connected directly to an FT232R or similar"
+arch=("i686" "x86_64")
+url="https://github.com/dcwbrown/dwire-debug"
+license=("GPL2")
+depends=("gtk3")
+conflict=("dwire-debug")
+source=("git+https://github.com/dcwbrown/dwire-debug.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make dwdebug || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ #make DESTDIR="${pkgdir}/" install
+ #cd "${srcdir}/${pkgname}/src"
+ install -D --mode=0755 dwdebug "${pkgdir}/usr/bin/dwdebug"
+}
+
+#
+# EOF
+#