summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Phillips2019-05-27 19:16:21 +1200
committerDavid Phillips2019-05-27 19:18:12 +1200
commita5007be2f952166c76e602ed93c819110849bd18 (patch)
tree7920dfe34fb51fcff5aa36fbfa523a93143555d6
parentf091f4ae351b8acba793190014ba51437872bb6d (diff)
downloadaur-a5007be2f952166c76e602ed93c819110849bd18.tar.gz
Bump to 6.2
Includes update of config.h to upstream config.def.h. Also moves to SHA256 for checksums since this is what upstream provides at https://dl.suckless.org/dwm/sha256sums.txt
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--config.h26
3 files changed, 33 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c76b58426cca..5889b2090faf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Nov 20 15:36:34 UTC 2017
pkgbase = dwm
pkgdesc = A dynamic window manager for X
- pkgver = 6.1
- pkgrel = 3
+ pkgver = 6.2
+ pkgrel = 1
url = http://dwm.suckless.org
install = dwm.install
arch = i686
@@ -16,12 +14,12 @@ pkgbase = dwm
depends = st
depends = dmenu
options = zipman
- source = http://dl.suckless.org/dwm/dwm-6.1.tar.gz
+ source = http://dl.suckless.org/dwm/dwm-6.2.tar.gz
source = config.h
source = dwm.desktop
- md5sums = f0b6b1093b7207f89c2a90b848c008ec
- md5sums = 80c4ef2a3eca0fe2d14e2203e3833200
- md5sums = 939f403a71b6e85261d09fc3412269ee
+ sha256sums = 97902e2e007aaeaa3c6e3bed1f81785b817b7413947f1db1d3b62b8da4cd110e
+ sha256sums = ce156c4ff6be6f664f5c1eb41e8ae8228c15d0282410be3ecdd58598bb8867d2
+ sha256sums = bc36426772e1471d6dd8c8aed91f288e16949e3463a9933fee6390ee0ccd3f81
pkgname = dwm
diff --git a/PKGBUILD b/PKGBUILD
index bb62ff383c64..ea2c72e33365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Grigorios Bouzakis <grbzks@gmail.com>
pkgname=dwm
-pkgver=6.1
-pkgrel=3
+pkgver=6.2
+pkgrel=1
pkgdesc="A dynamic window manager for X"
url="http://dwm.suckless.org"
arch=('i686' 'x86_64')
@@ -16,24 +16,24 @@ install=dwm.install
source=(http://dl.suckless.org/dwm/dwm-$pkgver.tar.gz
config.h
dwm.desktop)
-md5sums=('f0b6b1093b7207f89c2a90b848c008ec'
- '80c4ef2a3eca0fe2d14e2203e3833200'
- '939f403a71b6e85261d09fc3412269ee')
+sha256sums=('97902e2e007aaeaa3c6e3bed1f81785b817b7413947f1db1d3b62b8da4cd110e'
+ 'ce156c4ff6be6f664f5c1eb41e8ae8228c15d0282410be3ecdd58598bb8867d2'
+ 'bc36426772e1471d6dd8c8aed91f288e16949e3463a9933fee6390ee0ccd3f81')
prepare() {
- cd $srcdir/$pkgname-$pkgver
- cp $srcdir/config.h config.h
+ cd "$srcdir/$pkgname-$pkgver"
+ cp "$srcdir/config.h" config.h
}
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$srcdir/$pkgname-$pkgver"
make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 FREETYPEINC=/usr/include/freetype2
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make PREFIX=/usr DESTDIR=$pkgdir install
- install -m644 -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -m644 -D README $pkgdir/usr/share/doc/$pkgname/README
- install -m644 -D $srcdir/dwm.desktop $pkgdir/usr/share/xsessions/dwm.desktop
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -m644 -D "$srcdir/dwm.desktop" "$pkgdir/usr/share/xsessions/dwm.desktop"
}
diff --git a/config.h b/config.h
index 7054c06dd83e..1c0b587bda10 100644
--- a/config.h
+++ b/config.h
@@ -1,20 +1,22 @@
/* See LICENSE file for copyright and license details. */
/* appearance */
-static const char *fonts[] = {
- "monospace:size=10"
-};
-static const char dmenufont[] = "monospace:size=10";
-static const char normbordercolor[] = "#444444";
-static const char normbgcolor[] = "#222222";
-static const char normfgcolor[] = "#bbbbbb";
-static const char selbordercolor[] = "#005577";
-static const char selbgcolor[] = "#005577";
-static const char selfgcolor[] = "#eeeeee";
static const unsigned int borderpx = 1; /* border pixel of windows */
static const unsigned int snap = 32; /* snap pixel */
static const int showbar = 1; /* 0 means no bar */
static const int topbar = 1; /* 0 means bottom bar */
+static const char *fonts[] = { "monospace:size=10" };
+static const char dmenufont[] = "monospace:size=10";
+static const char col_gray1[] = "#222222";
+static const char col_gray2[] = "#444444";
+static const char col_gray3[] = "#bbbbbb";
+static const char col_gray4[] = "#eeeeee";
+static const char col_cyan[] = "#005577";
+static const char *colors[][3] = {
+ /* fg bg border */
+ [SchemeNorm] = { col_gray3, col_gray1, col_gray2 },
+ [SchemeSel] = { col_gray4, col_cyan, col_cyan },
+};
/* tagging */
static const char *tags[] = { "1", "2", "3", "4", "5", "6", "7", "8", "9" };
@@ -54,7 +56,7 @@ static const Layout layouts[] = {
/* commands */
static char dmenumon[2] = "0"; /* component of dmenucmd, manipulated in spawn() */
-static const char *dmenucmd[] = { "dmenu_run", "-m", dmenumon, "-fn", dmenufont, "-nb", normbgcolor, "-nf", normfgcolor, "-sb", selbgcolor, "-sf", selfgcolor, NULL };
+static const char *dmenucmd[] = { "dmenu_run", "-m", dmenumon, "-fn", dmenufont, "-nb", col_gray1, "-nf", col_gray3, "-sb", col_cyan, "-sf", col_gray4, NULL };
static const char *termcmd[] = { "st", NULL };
static Key keys[] = {
@@ -95,7 +97,7 @@ static Key keys[] = {
};
/* button definitions */
-/* click can be ClkLtSymbol, ClkStatusText, ClkWinTitle, ClkClientWin, or ClkRootWin */
+/* click can be ClkTagBar, ClkLtSymbol, ClkStatusText, ClkWinTitle, ClkClientWin, or ClkRootWin */
static Button buttons[] = {
/* click event mask button function argument */
{ ClkLtSymbol, 0, Button1, setlayout, {0} },