summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Down2015-08-07 17:41:13 +0100
committerChris Down2015-08-07 17:45:50 +0100
commitf5142d62e53c938f42181700b7e727f81928bb22 (patch)
tree1a1c2575280add54c3c8b4ba507e03a790316703
downloadaur-f5142d62e53c938f42181700b7e727f81928bb22.tar.gz
Import pkgrel 1 from old AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1ffb7e1b91f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dwm-cdown-git
+ pkgdesc = dwm with cdown's personalisations
+ pkgver = 0.r1744.a117eb9
+ pkgrel = 1
+ url = https://github.com/cdown/dwm
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = libx11
+ depends = libxinerama
+ provides = dwm
+ conflicts = dwm
+ source = git://github.com/cdown/dwm.git
+ md5sums = SKIP
+
+pkgname = dwm-cdown-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06b90c7a1acc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Chris Down <chris@chrisdown.name>
+
+pkgname=dwm-cdown-git
+_gitname=dwm
+pkgver=0.r1744.a117eb9
+pkgrel=1
+pkgdesc="dwm with cdown's personalisations"
+license=('MIT')
+url='https://github.com/cdown/dwm'
+depends=('libx11' 'libxinerama')
+arch=('any')
+makedepends=('git')
+conflicts=('dwm')
+provides=('dwm')
+
+source=('git://github.com/cdown/dwm.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf '0.r%s.%s' \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}