summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro López-Valencia2017-08-24 14:38:24 -0500
committerAlejandro López-Valencia2017-08-24 14:38:24 -0500
commitd8d56ca8b9bfb5438a77734d4624efbd44d5b567 (patch)
treee70fd62c7bb8803690961a2c9be1fe3c5ce19d51
downloadaur-d8d56ca8b9bfb5438a77734d4624efbd44d5b567.tar.gz
version 5.2
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2047b4292a41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dwm-gnome
+ pkgdesc = Starts suckless dwm wrapped in a gnome session.
+ pkgver = 5.2
+ pkgrel = 1
+ url = https://github.com/palopezv/dwm-gnome/
+ arch = any
+ license = MIT
+ depends = dwm
+ source = dwm-gnome-5.2.tar.gz::https://github.com/palopezv/dwm-gnome/archive/5.2.tar.gz
+ sha384sums = d6d5d2448090e03949a13ee398ec1d207855a3955256924c532794456bade291d28938253a2ec26405610bce695b950f
+
+pkgname = dwm-gnome
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c9c503b7b783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*~
+*.gz
+*.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cb82a3dfaff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: <https://aur.archlinux.org/users/vorbote>
+
+pkgname=dwm-gnome
+pkgver=5.2
+pkgrel=1
+pkgdesc="Starts suckless dwm wrapped in a gnome session."
+arch=('any')
+url="https://github.com/palopezv/dwm-gnome/"
+license=('MIT')
+depends=('dwm')
+source=($pkgname-$pkgver.tar.gz::https://github.com/palopezv/dwm-gnome/archive/$pkgver.tar.gz)
+sha384sums=('d6d5d2448090e03949a13ee398ec1d207855a3955256924c532794456bade291d28938253a2ec26405610bce695b950f')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make
+
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+}