aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranselm@garbe.us2012-01-04 13:30:12 +0100
committeranselm@garbe.us2012-01-04 13:30:12 +0100
commit192a105ab4c787e476df3b09889a3eefbc1ec498 (patch)
treeb2af8ada0cdb7be5673aee3fc1759058128954b3
parent60dcb4d7de19d45d02aa89e21a4c401010f2534a (diff)
downloadaur-192a105ab4c787e476df3b09889a3eefbc1ec498.tar.gz
config.mk cleanup
-rw-r--r--config.mk19
1 files changed, 9 insertions, 10 deletions
diff --git a/config.mk b/config.mk
index 484554a30c3f..7bb1c7cb0aa6 100644
--- a/config.mk
+++ b/config.mk
@@ -1,5 +1,5 @@
# dwm version
-VERSION = 6.0
+VERSION = 6.0-tip
# Customize below to fit your system
@@ -10,20 +10,19 @@ MANPREFIX = ${PREFIX}/share/man
X11INC = /usr/X11R6/include
X11LIB = /usr/X11R6/lib
-# Xinerama
-XINERAMALIBS = -L${X11LIB} -lXinerama
+# Xinerama, comment if you don't want it
+XINERAMALIBS = -lXinerama
XINERAMAFLAGS = -DXINERAMA
# includes and libs
-INCS = -I. -I/usr/include -I${X11INC}
-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
+INCS = -I${X11INC}
+LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS}
# flags
-CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
-#CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-#LDFLAGS = -g ${LIBS}
-LDFLAGS = -s ${LIBS}
+CPPFLAGS = -D_BSD_SOURCE -D_POSIX_C_SOURCE=2 -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+#CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+LDFLAGS = -s ${LIBS}
# Solaris
#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"