aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnselm R Garbe2008-08-02 19:12:15 +0100
committerAnselm R Garbe2008-08-02 19:12:15 +0100
commitbb3980b9ab5db8ae6786a75c5ac2f57da2481f79 (patch)
tree2acfa5a43d424d020a69fd154d770760715b0aab
parentcf4e0c18f7395dc80e2c248ff633c82e37a71cd4 (diff)
downloadaur-bb3980b9ab5db8ae6786a75c5ac2f57da2481f79.tar.gz
made readin a config.h variable
-rw-r--r--config.def.h1
-rw-r--r--config.mk2
-rw-r--r--dwm.c3
3 files changed, 3 insertions, 3 deletions
diff --git a/config.def.h b/config.def.h
index 5908ed9029e0..aafff8aa6cb3 100644
--- a/config.def.h
+++ b/config.def.h
@@ -12,6 +12,7 @@ static unsigned int borderpx = 1; /* border pixel of windows */
static unsigned int snap = 32; /* snap pixel */
static Bool showbar = True; /* False means no bar */
static Bool topbar = True; /* False means bottom bar */
+static Bool readin = True; /* False means do not read stdin */
/* tagging */
static const char tags[][MAXTAGLEN] = { "1", "2", "3", "4", "5", "6", "7", "8", "9" };
diff --git a/config.mk b/config.mk
index 254ec5398857..9e4636af7492 100644
--- a/config.mk
+++ b/config.mk
@@ -1,5 +1,5 @@
# dwm version
-VERSION = 5.1
+VERSION = 5.2
# Customize below to fit your system
diff --git a/dwm.c b/dwm.c
index 5f3b9c945af7..279f831f8a3c 100644
--- a/dwm.c
+++ b/dwm.c
@@ -224,7 +224,7 @@ static void (*handler[LASTEvent]) (XEvent *) = {
[UnmapNotify] = unmapnotify
};
static Atom wmatom[WMLast], netatom[NetLast];
-static Bool otherwm, readin;
+static Bool otherwm;
static Bool running = True;
static unsigned int tagset[] = {1, 1}; /* after start, first tag is selected */
static Client *clients = NULL;
@@ -1219,7 +1219,6 @@ run(void) {
/* main event loop, also reads status text from stdin */
XSync(dpy, False);
xfd = ConnectionNumber(dpy);
- readin = True;
offset = 0;
len = sizeof stext - 1;
sbuf[len] = stext[len] = '\0'; /* 0-terminator is never touched */