summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob McDonnell2020-06-08 13:42:02 -0400
committerJacob McDonnell2020-06-08 13:42:02 -0400
commitd18eef4ee35e960747aa6187bb9f0c9925a10903 (patch)
tree66c2fdf643c633a33341ad17353546f683bd6086
downloadaur-d18eef4ee35e960747aa6187bb9f0c9925a10903.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01096b605afe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dwm-jacob-git
+ pkgdesc = This Jacob McDonnell's build of dwm see the repo for more details
+ pkgver = 6.2.r2.ee100fa
+ pkgrel = 1
+ url = https://gitlab.com/Jacob_McDonnell/dwm.git
+ arch = x86_64
+ arch = i686
+ license = MIT/X Consortium License
+ makedepends = git
+ makedepends = make
+ depends = libxft-bgra
+ optdepends = dwmblocks
+ provides = dwm
+ conflicts = dwm
+ source = git+https://gitlab.com/Jacob_McDonnell/dwm.git
+ md5sums = SKIP
+
+pkgname = dwm-jacob-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86d56fd22a88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=dwm-jacob-git
+pkgver=6.2.r2.ee100fa
+pkgrel=1
+pkgdesc="This Jacob McDonnell's build of dwm see the repo for more details"
+arch=(x86_64 i686)
+url="https://gitlab.com/Jacob_McDonnell/dwm.git"
+license=('MIT/X Consortium License')
+depends=(libxft-bgra)
+makedepends=(git make)
+optdepends=(dwmblocks)
+provides=(dwm)
+conflicts=(dwm)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver(){
+ cd dwm
+ _pkgver=$(awk '/VERSION/ {print $3}' config.mk|head -1)
+ echo "${_pkgver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd dwm
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -rf * ${pkgdir}/opt/${pkgname}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}