summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornho1ix2020-09-24 22:57:43 -0700
committernho1ix2020-09-24 22:57:43 -0700
commit73af6bbdfcd11cbbae0da7e615e897145c4bb798 (patch)
treef8424f3890a0142ba13067dfb71f1cfeec39c2b6
downloadaur-73af6bbdfcd11cbbae0da7e615e897145c4bb798.tar.gz
Initial Push
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD48
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c41bd486c16e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = dwm-nho1ix-git
+ pkgdesc = Nho1ix's patched build of dwm.
+ pkgver = 6.2.r1845.afaddc4
+ pkgrel = 1
+ url = https://github.com/nho1ix/dwm.git
+ arch = any
+ groups = base-devel
+ license = MIT
+ makedepends = make
+ depends = libx11
+ depends = libxinerama
+ depends = libxft-bgra-git
+ depends = otf-hermit
+ depends = ttf-font-awesome
+ depends = freetype2
+ optdepends = dunst
+ optdepends = ios-emoji
+ provides = dwm
+ conflicts = dwm
+ replaces = dwm
+ replaces = dwm-distrotube-git
+ source = git+https://github.com/nho1ix/dwm.git
+ md5sums = SKIP
+
+pkgname = dwm-nho1ix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a7d86f9a18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: nho1ix <phuongnhoclu@gmail.com>
+pkgname=dwm-nho1ix-git
+pkgver=6.2.r1845.afaddc4
+pkgrel=1
+pkgdesc="nho1ix's patched build of dwm."
+arch=(any)
+url="https://github.com/nho1ix/dwm.git"
+license=('MIT')
+groups=(base-devel)
+depends=(libx11 libxinerama libxft-bgra-git otf-hermit ttf-font-awesome freetype2)
+makedepends=(make)
+optdepends=(dunst ios-emoji)
+provides=(dwm)
+conflicts=(dwm)
+replaces=(dwm dwm-distrotube-git)
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "6.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "dwm"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 FREETYPEINC=/usr/include/freetype2
+}
+
+package() {
+ cd dwm
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -rf * ${pkgdir}/opt/${pkgname}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/dwm/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/dwm/README.md"
+# install -Dm644 "${srcdir}/dwm/dwm.desktop" "$pkgdir/usr/share/xsessions/dwm.desktop"
+}