summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroakszyjrnrdy2020-09-10 03:29:39 +0800
committeroakszyjrnrdy2020-09-10 03:29:39 +0800
commitd2aeec7fdb29981c4e4937087403fc6236daaf58 (patch)
tree737ca1df6ebfb74ad180f7fdd352fcaa390093c4
downloadaur-d2aeec7fdb29981c4e4937087403fc6236daaf58.tar.gz
feat: init commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD53
-rw-r--r--dwm-autostart-6.2.diff39
-rw-r--r--dwm-config-6.2.diff55
-rw-r--r--dwm.desktop7
5 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bd9df2c3028
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = dwm-oakszyjrnrdy
+ pkgdesc = A dynamic window manager for X built by oakszyjrnrdy
+ pkgver = 6.2
+ pkgrel = 1
+ url = http://dwm.suckless.org
+ arch = x86_64
+ license = MIT
+ depends = libx11
+ depends = libxinerama
+ depends = libxft
+ depends = freetype2
+ depends = alacritty
+ depends = dmenu
+ provides = dwm
+ conflicts = dwm
+ options = zipman
+ source = https://dl.suckless.org/dwm/dwm-6.2.tar.gz
+ source = dwm.desktop
+ source = dwm-config-6.2.diff
+ source = dwm-autostart-6.2.diff
+ source = https://dwm.suckless.org/patches/hide_vacant_tags/dwm-hide_vacant_tags-6.2.diff
+ source = https://dwm.suckless.org/patches/alpha/dwm-fixborders-6.2.diff
+ source = https://dwm.suckless.org/patches/noborder/dwm-noborder-6.2.diff
+ sha256sums = 97902e2e007aaeaa3c6e3bed1f81785b817b7413947f1db1d3b62b8da4cd110e
+ sha256sums = bc36426772e1471d6dd8c8aed91f288e16949e3463a9933fee6390ee0ccd3f81
+ sha256sums = 6724ead226c14eb546952550001eb9dcf069627804b72a6a9bfc22a76af00fd3
+ sha256sums = c978561abde2df339ef6bab73a1eaf9ad097db1038e46f6de0247b1aea35a5a2
+ sha256sums = 716d43cda73744abbe12c1ecd20fd55769c2a36730a57d0a12c09c06854b7fa8
+ sha256sums = 0343dccd71cb8a3f4a18637ea51f4764a51cda5d712092a103bac5cba7dfc7ad
+ sha256sums = 9bbf5f963e5a2d23ae4b8731f0c179a8615de5715a2dbf683fbe02115e24efe0
+
+pkgname = dwm-oakszyjrnrdy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d7eae0d3ec9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: oakszyjrnrdy <oakszyjrnrdy at outlook dot com>
+_pkgname="dwm"
+pkgname="$_pkgname-oakszyjrnrdy"
+pkgver=6.2
+pkgrel=1
+pkgdesc="A dynamic window manager for X built by oakszyjrnrdy"
+url="http://dwm.suckless.org"
+arch=("x86_64")
+license=("MIT")
+options=("zipman")
+depends=("libx11" "libxinerama" "libxft" "freetype2" "alacritty" "dmenu")
+provides=("dwm")
+conflicts=("dwm")
+source=(
+ "https://dl.suckless.org/dwm/$_pkgname-$pkgver.tar.gz"
+ "dwm.desktop"
+ "dwm-config-6.2.diff"
+ "dwm-autostart-6.2.diff"
+ "https://dwm.suckless.org/patches/hide_vacant_tags/dwm-hide_vacant_tags-6.2.diff"
+ "https://dwm.suckless.org/patches/alpha/dwm-fixborders-6.2.diff"
+ "https://dwm.suckless.org/patches/noborder/dwm-noborder-6.2.diff"
+)
+sha256sums=(
+ "97902e2e007aaeaa3c6e3bed1f81785b817b7413947f1db1d3b62b8da4cd110e"
+ "bc36426772e1471d6dd8c8aed91f288e16949e3463a9933fee6390ee0ccd3f81"
+ "6724ead226c14eb546952550001eb9dcf069627804b72a6a9bfc22a76af00fd3"
+ "c978561abde2df339ef6bab73a1eaf9ad097db1038e46f6de0247b1aea35a5a2"
+ "716d43cda73744abbe12c1ecd20fd55769c2a36730a57d0a12c09c06854b7fa8"
+ "0343dccd71cb8a3f4a18637ea51f4764a51cda5d712092a103bac5cba7dfc7ad"
+ "9bbf5f963e5a2d23ae4b8731f0c179a8615de5715a2dbf683fbe02115e24efe0"
+)
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch --strip=1 --input=../dwm-config-6.2.diff
+ patch --strip=1 --input=../dwm-autostart-6.2.diff
+ patch --strip=1 --input=../dwm-hide_vacant_tags-6.2.diff
+ patch --strip=1 --input=../dwm-fixborders-6.2.diff
+ patch --strip=1 --input=../dwm-noborder-6.2.diff
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make X11INC="/usr/include/X11" X11LIB="/usr/lib/X11"
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -m644 -D "$srcdir/dwm.desktop" "$pkgdir/usr/share/xsessions/dwm.desktop"
+}
diff --git a/dwm-autostart-6.2.diff b/dwm-autostart-6.2.diff
new file mode 100644
index 000000000000..cb0486a6e494
--- /dev/null
+++ b/dwm-autostart-6.2.diff
@@ -0,0 +1,39 @@
+commit 5918623c5bd7fda155bf9dc3d33890c4ae1722d0
+Author: Simon Bremer <simon.bremer@tum.de>
+Date: Thu Dec 22 17:31:07 2016 +0100
+
+ Applied and fixed autostart patch for previous version;
+
+diff --git a/dwm.c b/dwm.c
+index d27cb67..066ed71 100644
+--- a/dwm.c
++++ b/dwm.c
+@@ -194,6 +194,7 @@ static void resizeclient(Client *c, int x, int y, int w, int h);
+ static void resizemouse(const Arg *arg);
+ static void restack(Monitor *m);
+ static void run(void);
++static void runAutostart(void);
+ static void scan(void);
+ static int sendevent(Client *c, Atom proto);
+ static void sendmon(Client *c, Monitor *m);
+@@ -1386,6 +1387,12 @@ run(void)
+ }
+
+ void
++runAutostart(void) {
++ system("[ -x ~/.config/dwm/autostart_blocking.sh ] && ~/.config/dwm/autostart_blocking.sh");
++ system("[ -x ~/.config/dwm/autostart.sh ] && ~/.config/dwm/autostart.sh &");
++}
++
++void
+ scan(void)
+ {
+ unsigned int i, num;
+@@ -2145,6 +2152,7 @@ main(int argc, char *argv[])
+ checkotherwm();
+ setup();
+ scan();
++ runAutostart();
+ run();
+ cleanup();
+ XCloseDisplay(dpy);
diff --git a/dwm-config-6.2.diff b/dwm-config-6.2.diff
new file mode 100644
index 000000000000..f13a01fa5aec
--- /dev/null
+++ b/dwm-config-6.2.diff
@@ -0,0 +1,55 @@
+--- a/config.def.h 2020-09-10 03:08:40.220047365 +0800
++++ b/config.def.h 2020-09-10 03:21:30.310052738 +0800
+@@ -1,12 +1,20 @@
+ /* See LICENSE file for copyright and license details. */
+
+ /* appearance */
+-static const unsigned int borderpx = 1; /* border pixel of windows */
++static const unsigned int borderpx = 6; /* border pixel of windows */
+ static const unsigned int snap = 32; /* snap pixel */
+ static const int showbar = 1; /* 0 means no bar */
+ static const int topbar = 1; /* 0 means bottom bar */
+-static const char *fonts[] = { "monospace:size=10" };
+-static const char dmenufont[] = "monospace:size=10";
++static const char *fonts[] = {
++ "monospace:size=14",
++ "Noto Sans CJK SC:size=14",
++ "Noto Sans CJK TC:size=14",
++ "Noto Sans CJK HK:size=14",
++ "Noto Sans CJK JP:size=14",
++ "Noto Sans CJK KR:size=14",
++ "Noto Color Emoji:size=14"
++};
++static const char dmenufont[] = "monospace:size=14";
+ static const char col_gray1[] = "#222222";
+ static const char col_gray2[] = "#444444";
+ static const char col_gray3[] = "#bbbbbb";
+@@ -28,7 +36,9 @@
+ */
+ /* class instance title tags mask isfloating monitor */
+ { "Gimp", NULL, NULL, 0, 1, -1 },
+- { "Firefox", NULL, NULL, 1 << 8, 0, -1 },
++ { "Nightly", NULL, NULL, 1 << 1, 0, -1 },
++ { "Qemu-system-x86_64", "qemu", NULL, 0, 1, -1 },
++ { "Steam", "Steam", NULL, 1 << 8, 0, -1 },
+ };
+
+ /* layout(s) */
+@@ -44,7 +54,7 @@
+ };
+
+ /* key definitions */
+-#define MODKEY Mod1Mask
++#define MODKEY Mod4Mask
+ #define TAGKEYS(KEY,TAG) \
+ { MODKEY, KEY, view, {.ui = 1 << TAG} }, \
+ { MODKEY|ControlMask, KEY, toggleview, {.ui = 1 << TAG} }, \
+@@ -57,7 +67,7 @@
+ /* commands */
+ static char dmenumon[2] = "0"; /* component of dmenucmd, manipulated in spawn() */
+ static const char *dmenucmd[] = { "dmenu_run", "-m", dmenumon, "-fn", dmenufont, "-nb", col_gray1, "-nf", col_gray3, "-sb", col_cyan, "-sf", col_gray4, NULL };
+-static const char *termcmd[] = { "st", NULL };
++static const char *termcmd[] = { "alacritty", NULL };
+
+ static Key keys[] = {
+ /* modifier key function argument */
diff --git a/dwm.desktop b/dwm.desktop
new file mode 100644
index 000000000000..b0c33541ba30
--- /dev/null
+++ b/dwm.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Dwm
+Comment=Dynamic window manager
+Exec=dwm
+Icon=dwm
+Type=XSession