summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2023-10-16 06:54:53 +0000
committerFlorian Hülsmann2023-10-16 06:54:53 +0000
commit2dd69545a77fc585d623b0060656deac9e6e8cde (patch)
treeb7698643d50463a20cc70451ffed259d2c9055f8
parent0ebadb828d5cc3c4059511aa3ea8fe67583f240b (diff)
downloadaur-2dd69545a77fc585d623b0060656deac9e6e8cde.tar.gz
dxconvert: update to v3.2.1 and add to AUR list (#287)
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5174e48a68ab..b0a6f825120d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = dxconvert
pkgdesc = A file conversion and manipulation toolkit for Yamaha FM synth patches
- pkgver = 3.1.7
+ pkgver = 3.2.1
pkgrel = 1
url = http://dxconvert.martintarenskeen.nl/
arch = any
groups = pro-audio
license = GPL3
depends = python
- optdepends = castools: convert Cassette Interface data (DX100/27/21, DX9, TX81Z)
- optdepends = python-rtmidi: MIDI input/output
optdepends = tk: dxconvert and txconvert GUI
optdepends = zbar: convert patches from QR codes to SysEx
- source = http://home.kpn.nl/m.tarenskeen/download/sysex/DXconvert/DXconvert-3.1.7.zip
- sha256sums = 3c389ef5bacfe2610887c677f0607cc0aa80d9092c21fe8b945898c49b379c08
+ source = https://dxconvert.martintarenskeen.nl/DXconvert-3.2.1.zip
+ sha256sums = 3495e3ee1f60e556001a7ab03dddec4fb190e2f1cbdc3f3503311d3f43181a21
pkgname = dxconvert
diff --git a/.gitignore b/.gitignore
index 79508ef792e3..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
-dxconvert-*.pkg.tar.xz
-dxconvert-*.pkg.tar.zst
-DXconvert-*.zip
pkg/
src/
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 8371db43d76c..0294e7cd9920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
_name=DXconvert
pkgname=${_name,,}
-pkgver=3.1.7
+pkgver=3.2.1
pkgrel=1
pkgdesc='A file conversion and manipulation toolkit for Yamaha FM synth patches'
arch=(any)
@@ -10,14 +11,21 @@ url='http://dxconvert.martintarenskeen.nl/'
license=(GPL3)
depends=(python)
optdepends=(
- 'castools: convert Cassette Interface data (DX100/27/21, DX9, TX81Z)'
- 'python-rtmidi: MIDI input/output'
+ # We can't package castools for our repo, since it has neither a source dist
+ # nor a git tag for a current release.
+ #'castools: convert Cassette Interface data (DX100/27/21, DX9, TX81Z)'
'tk: dxconvert and txconvert GUI'
'zbar: convert patches from QR codes to SysEx'
)
groups=(pro-audio)
-source=("http://home.kpn.nl/m.tarenskeen/download/sysex/$_name/$_name-$pkgver.zip")
-sha256sums=('3c389ef5bacfe2610887c677f0607cc0aa80d9092c21fe8b945898c49b379c08')
+source=("https://dxconvert.martintarenskeen.nl/$_name-$pkgver.zip")
+sha256sums=('3495e3ee1f60e556001a7ab03dddec4fb190e2f1cbdc3f3503311d3f43181a21')
+
+prepare() {
+ cd $_name-$pkgver
+ # Fix broken shebang
+ sed -i -e 's|#!/env|#!/usr/bin/env|' dxconvert-gui.py
+}
package() {
cd $_name-$pkgver
@@ -32,9 +40,6 @@ package() {
install -Dm755 "$py" "$pkgdir"/usr/bin/${py%.py}
done
- # install MIDI configuration helper script
- install -Dm755 midi_help.pyw "$pkgdir"/usr/bin/dxconvert-midi-help
-
# install scripts in Tools dir
for tool in Tools/*.py; do
bn="${tool##*/}"