summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrius Lukosevicius2022-11-26 08:42:50 +0200
committerAndrius Lukosevicius2022-11-26 08:42:50 +0200
commite5eac7e92b0459aa0c851dcf9c42d2df14db33fe (patch)
tree93bae7bc88ef95cef73e5c7465458c515731ad44
parent7d5be28261b1a0bedba050b250128aacb811b307 (diff)
downloadaur-e5eac7e92b0459aa0c851dcf9c42d2df14db33fe.tar.gz
Upstream removed setup script, so ship our own copy.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--setup_dxvk.sh206
3 files changed, 218 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22453ede27d2..b3bc9c94fc99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-async-git
pkgdesc = A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)
- pkgver = 2.0.r0.g8f8a9369
+ pkgver = 2.0.r23.g57176e77
pkgrel = 1
url = https://github.com/Sporif/dxvk-async.git
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = dxvk-async-git
depends = lib32-vulkan-icd-loader
provides = dxvk
provides = d9vk
- provides = dxvk=2.0.r0.g8f8a9369
+ provides = dxvk=2.0.r23.g57176e77
conflicts = d9vk-mingw-git
conflicts = d9vk-bin
conflicts = d9vk-winelib-git
@@ -37,12 +37,14 @@ pkgbase = dxvk-async-git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = git+https://github.com/Sporif/dxvk-async.git
source = dxvk-async-env.conf
+ source = setup_dxvk.sh
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 5ea0fbf7fddb45a8575ff001793011a594d999aaeb66ef95378bca950c844300
+ sha256sums = 0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7
pkgname = dxvk-async-git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e8c023385c51..d8db514840dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=dxvk-async-git
pkgname=('dxvk-async-git')
-pkgver=2.0.r0.g8f8a9369
+pkgver=2.0.r23.g57176e77
pkgrel=1
pkgdesc="A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)"
arch=('x86_64')
@@ -19,13 +19,15 @@ source=("git+https://github.com/doitsujin/dxvk.git"
"git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"git+https://github.com/Sporif/dxvk-async.git"
- "dxvk-async-env.conf")
+ "dxvk-async-env.conf"
+ "setup_dxvk.sh")
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '5ea0fbf7fddb45a8575ff001793011a594d999aaeb66ef95378bca950c844300')
+ '5ea0fbf7fddb45a8575ff001793011a594d999aaeb66ef95378bca950c844300'
+ '0f688815530ab5e8cc89b9b45d9b1d66cd8cd5a7770fb8249339af555a30dfe7')
pkgver() {
cd dxvk
@@ -45,7 +47,7 @@ prepare() {
}
build() {
- meson dxvk "build/x64" \
+ meson setup dxvk "build/x64" \
--cross-file dxvk/build-win64.txt \
--prefix "/usr/share/dxvk/x64" \
--bindir "" --libdir "" \
@@ -53,7 +55,7 @@ build() {
--strip
ninja -C "build/x64"
- meson dxvk "build/x32" \
+ meson setup dxvk "build/x32" \
--cross-file dxvk/build-win32.txt \
--prefix "/usr/share/dxvk/x32" \
--bindir "" --libdir "" \
@@ -67,7 +69,7 @@ package_dxvk-async-git() {
conflicts=("dxvk-bin" "dxvk-mingw-git")
DESTDIR="$pkgdir" ninja -C "build/x32" install
DESTDIR="$pkgdir" ninja -C "build/x64" install
- install -Dm 644 dxvk/setup_dxvk.sh "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
+ install -Dm 644 "$srcdir/setup_dxvk.sh" "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
mkdir -p "$pkgdir/usr/bin"
ln -s /usr/share/dxvk/setup_dxvk.sh "$pkgdir/usr/bin/setup_dxvk"
chmod +x "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
diff --git a/setup_dxvk.sh b/setup_dxvk.sh
new file mode 100644
index 000000000000..0f1998f30d99
--- /dev/null
+++ b/setup_dxvk.sh
@@ -0,0 +1,206 @@
+#!/usr/bin/env bash
+
+# default directories
+dxvk_lib32=${dxvk_lib32:-"x32"}
+dxvk_lib64=${dxvk_lib64:-"x64"}
+
+# figure out where we are
+basedir="$(dirname "$(readlink -f "$0")")"
+
+# figure out which action to perform
+action="$1"
+
+case "$action" in
+install)
+ ;;
+uninstall)
+ ;;
+*)
+ echo "Unrecognized action: $action"
+ echo "Usage: $0 [install|uninstall] [--without-dxgi] [--symlink]"
+ exit 1
+esac
+
+# process arguments
+shift
+
+with_dxgi=true
+file_cmd="cp -v --reflink=auto"
+
+while (($# > 0)); do
+ case "$1" in
+ "--without-dxgi")
+ with_dxgi=false
+ ;;
+ "--symlink")
+ file_cmd="ln -s -v"
+ ;;
+ esac
+ shift
+done
+
+# check wine prefix before invoking wine, so that we
+# don't accidentally create one if the user screws up
+if [ -n "$WINEPREFIX" ] && ! [ -f "$WINEPREFIX/system.reg" ]; then
+ echo "$WINEPREFIX:"' Not a valid wine prefix.' >&2
+ exit 1
+fi
+
+# find wine executable
+export WINEDEBUG=-all
+# disable mscoree and mshtml to avoid downloading
+# wine gecko and mono
+export WINEDLLOVERRIDES="mscoree,mshtml="
+
+wine="wine"
+wine64="wine64"
+wineboot="wineboot"
+
+# $PATH is the way for user to control where wine is located (including custom Wine versions).
+# Pure 64-bit Wine (non Wow64) requries skipping 32-bit steps.
+# In such case, wine64 and winebooot will be present, but wine binary will be missing,
+# however it can be present in other PATHs, so it shouldn't be used, to avoid versions mixing.
+wine_path=$(dirname "$(which $wineboot)")
+wow64=true
+if ! [ -f "$wine_path/$wine" ]; then
+ wine=$wine64
+ wow64=false
+fi
+
+# resolve 32-bit and 64-bit system32 path
+winever=$($wine --version | grep wine)
+if [ -z "$winever" ]; then
+ echo "$wine:"' Not a wine executable. Check your $wine.' >&2
+ exit 1
+fi
+
+# ensure wine placeholder dlls are recreated
+# if they are missing
+$wineboot -u
+
+win64_sys_path=$($wine64 winepath -u 'C:\windows\system32' 2> /dev/null)
+win64_sys_path="${win64_sys_path/$'\r'/}"
+if $wow64; then
+ win32_sys_path=$($wine winepath -u 'C:\windows\system32' 2> /dev/null)
+ win32_sys_path="${win32_sys_path/$'\r'/}"
+fi
+
+if [ -z "$win32_sys_path" ] && [ -z "$win64_sys_path" ]; then
+ echo 'Failed to resolve C:\windows\system32.' >&2
+ exit 1
+fi
+
+# create native dll override
+overrideDll() {
+ $wine reg add 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v $1 /d native /f >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ echo -e "Failed to add override for $1"
+ exit 1
+ fi
+}
+
+# remove dll override
+restoreDll() {
+ $wine reg delete 'HKEY_CURRENT_USER\Software\Wine\DllOverrides' /v $1 /f > /dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ echo "Failed to remove override for $1"
+ fi
+}
+
+# copy or link dxvk dll, back up original file
+installFile() {
+ dstfile="${1}/${3}.dll"
+ srcfile="${basedir}/${2}/${3}.dll"
+
+ if [ -f "${srcfile}.so" ]; then
+ srcfile="${srcfile}.so"
+ fi
+
+ if ! [ -f "${srcfile}" ]; then
+ echo "${srcfile}: File not found. Skipping." >&2
+ return 1
+ fi
+
+ if [ -n "$1" ]; then
+ if [ -f "${dstfile}" ] || [ -h "${dstfile}" ]; then
+ if ! [ -f "${dstfile}.old" ]; then
+ mv -v "${dstfile}" "${dstfile}.old"
+ else
+ rm -v "${dstfile}"
+ fi
+ $file_cmd "${srcfile}" "${dstfile}"
+ else
+ echo "${dstfile}: File not found in wine prefix" >&2
+ return 1
+ fi
+ fi
+ return 0
+}
+
+# remove dxvk dll, restore original file
+uninstallFile() {
+ dstfile="${1}/${3}.dll"
+ srcfile="${basedir}/${2}/${3}.dll"
+
+ if [ -f "${srcfile}.so" ]; then
+ srcfile="${srcfile}.so"
+ fi
+
+ if ! [ -f "${srcfile}" ]; then
+ echo "${srcfile}: File not found. Skipping." >&2
+ return 1
+ fi
+
+ if ! [ -f "${dstfile}" ] && ! [ -h "${dstfile}" ]; then
+ echo "${dstfile}: File not found. Skipping." >&2
+ return 1
+ fi
+
+ if [ -f "${dstfile}.old" ]; then
+ rm -v "${dstfile}"
+ mv -v "${dstfile}.old" "${dstfile}"
+ return 0
+ else
+ return 1
+ fi
+}
+
+install() {
+ installFile "$win64_sys_path" "$dxvk_lib64" "$1"
+ inst64_ret="$?"
+
+ inst32_ret=-1
+ if $wow64; then
+ installFile "$win32_sys_path" "$dxvk_lib32" "$1"
+ inst32_ret="$?"
+ fi
+
+ if (( ($inst32_ret == 0) || ($inst64_ret == 0) )); then
+ overrideDll "$1"
+ fi
+}
+
+uninstall() {
+ uninstallFile "$win64_sys_path" "$dxvk_lib64" "$1"
+ uninst64_ret="$?"
+
+ uninst32_ret=-1
+ if $wow64; then
+ uninstallFile "$win32_sys_path" "$dxvk_lib32" "$1"
+ uninst32_ret="$?"
+ fi
+
+ if (( ($uninst32_ret == 0) || ($uninst64_ret == 0) )); then
+ restoreDll "$1"
+ fi
+}
+
+# skip dxgi during install if not explicitly
+# enabled, but always try to uninstall it
+if $with_dxgi || [ "$action" == "uninstall" ]; then
+ $action dxgi
+fi
+
+$action d3d9
+$action d3d10core
+$action d3d11