summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2018-03-02 08:39:14 +0100
committerAdrià Cereto-Massagué2018-03-02 08:39:14 +0100
commit09fe59770bbc55ae43eb0df0ba56c68665776e10 (patch)
treef42a0782bfb5b973902279fa474d8a7feaa63ea6
downloadaur-09fe59770bbc55ae43eb0df0ba56c68665776e10.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..192cf9b3215e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dxvk-bin
+ pkgdesc = A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine (binary files). Requires Wine with Vulkan support (wine-staging, wine-vulkan or wine >=3.3)
+ pkgver = 0.30
+ pkgrel = 1
+ url = https://github.com/doitsujin/dxvk
+ arch = x86_64
+ license = zlib/libpng
+ depends = vulkan-icd-loader
+ depends = wine
+ provides = dxvk
+ conflicts = dxvk-git
+ source = https://github.com/doitsujin/dxvk/releases/download/v0.30/dxvk-0.30.tar.gz
+ sha256sums = 797e997a992c3e3f1d4f0399a66fa8f4afef27f9d7913ea3acdc2fcf8c3be544
+
+pkgname = dxvk-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67bff84bf5b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Adrià Cereto i Massagué <ssorgatem at gmail.com>
+
+pkgname=dxvk-bin
+pkgver=0.30
+pkgrel=1
+epoch=
+pkgdesc="A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine (binary files). Requires Wine with Vulkan support (wine-staging, wine-vulkan or wine >=3.3)"
+arch=('x86_64')
+url="https://github.com/doitsujin/dxvk"
+license=('zlib/libpng')
+groups=()
+depends=('vulkan-icd-loader' 'wine')
+checkdepends=()
+provides=("dxvk")
+conflicts=("dxvk-git")
+replaces=()
+backup=()
+install=
+changelog=
+source=("https://github.com/doitsujin/dxvk/releases/download/v0.30/dxvk-0.30.tar.gz")
+noextract=()
+sha256sums=("797e997a992c3e3f1d4f0399a66fa8f4afef27f9d7913ea3acdc2fcf8c3be544")
+validpgpkeys=()
+
+
+build() {
+ tar xvf dxvk-0.30.tar.gz
+}
+
+
+
+package() {
+ mkdir -p $pkgdir/opt/dxvk
+ cp -r "dxvk-$pkgver"/x64 $pkgdir/opt/dxvk
+ cp -r "dxvk-$pkgver"/x64 $pkgdir/opt/dxvk
+ mkdir -p $pkgdir/usr/local/bin
+ ln -s "/opt/dxvk/x64/setup_dxvk.sh" "$pkgdir/usr/local/bin/setup_dxvk64"
+ ln -s "/opt/dxvk/x32/setup_dxvk.sh" "$pkgdir/usr/local/bin/setup_dxvk32"
+}