summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Van der Aa2019-09-28 09:34:09 +0200
committerJonas Van der Aa2019-09-28 09:34:09 +0200
commit0c4be3342cc43d07712ac06026d771bd3a17c2e5 (patch)
treeee7c2220d622dacea389ddb084535281a8449f83
parentfa778b96370cd9853be512572ddd41fa444c37ab (diff)
downloadaur-0c4be3342cc43d07712ac06026d771bd3a17c2e5.tar.gz
v1.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8f242b470b7..563af80c86dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = dxvk-bin
pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
- pkgver = 1.4.0
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
arch = i686
license = zlib/libpng
options = !strip
- source = https://github.com/doitsujin/dxvk/releases/download/v1.4/dxvk-1.4.tar.gz
- sha256sums = bf22785de1ce728bbdcfb4615035924112b4718049ca2cade5861b03735181de
+ source = https://github.com/doitsujin/dxvk/releases/download/v1.4.1/dxvk-1.4.1.tar.gz
+ sha256sums = 574ec4dc5201e45d70472228f0c6695426f0392503ec7a47d6092600aac53a07
pkgname = dxvk-bin
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f1190378d971..35a155f9431d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
pkgbase=dxvk-bin
pkgname=('dxvk-bin')
-pkgver=1.4.0
-realver=1.4
+pkgver=1.4.1
pkgrel=1
pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)"
arch=('x86_64' 'i686')
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
options=(!strip)
-source=("https://github.com/doitsujin/dxvk/releases/download/v$realver/dxvk-$realver.tar.gz"
+source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz"
)
-sha256sums=("bf22785de1ce728bbdcfb4615035924112b4718049ca2cade5861b03735181de")
+sha256sums=("574ec4dc5201e45d70472228f0c6695426f0392503ec7a47d6092600aac53a07")
package_dxvk-bin () {
arch=('x86_64')
@@ -20,8 +19,7 @@ package_dxvk-bin () {
depends=('vulkan-icd-loader' 'wine>=3.10' 'lib32-vulkan-icd-loader')
conflicts=("dxvk-git")
mkdir -p "$pkgdir/usr/share/dxvk"
- mv dxvk-"$realver".tar.gz dxvk-"$pkgver".tar.gz
- tar -xf dxvk-"$pkgver".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1 dxvk-"$realver"/
+ tar -xf dxvk-"$pkgver".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1 dxvk-"$pkgver"/
mkdir -p "$pkgdir/usr/bin"
ln -s /usr/share/dxvk/setup_dxvk.sh "$pkgdir/usr/bin/setup_dxvk"
chmod +x "$pkgdir/usr/share/dxvk/setup_dxvk.sh"