summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2019-04-15 18:21:28 +0200
committerAdrià Cereto-Massagué2019-04-15 18:21:28 +0200
commit1dcb7be945300ddb727e545ee847cb3adde6fe36 (patch)
tree31070655d965d1a5f98bb5e081181705c3fdcc67
parentdfd9ddad5eccb0e71f08a39c5c74e3c1ba0c37d5 (diff)
downloadaur-1dcb7be945300ddb727e545ee847cb3adde6fe36.tar.gz
1.0.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9562829e4d18..d83d2768702a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-bin
pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = dxvk-bin
provides = dxvk
conflicts = dxvk-git
options = !strip
- source = https://github.com/doitsujin/dxvk/releases/download/v1.0.2/dxvk-1.0.2.tar.gz
- sha256sums = f9504b188488d1102cba7e82c28681708f39e151af1c1ef7ebeac82d729c01ac
+ source = https://github.com/doitsujin/dxvk/releases/download/v1.0.3/dxvk-1.0.3.tar.gz
+ sha256sums = 984d28ab3a112be207d6339da19113d1117e56731ed413d0e202e6fd1391a6ae
pkgname = dxvk-win64-bin
pkgdesc = Dummy package
diff --git a/PKGBUILD b/PKGBUILD
index 71d4ee65dd31..6a9dac81d270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=dxvk-bin
pkgname=('dxvk-win64-bin' 'dxvk-win32-bin' 'dxvk-bin')
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)"
arch=('x86_64' 'i686')
@@ -13,7 +13,7 @@ conflicts=("dxvk-git")
options=(!strip)
source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz"
)
-sha256sums=("f9504b188488d1102cba7e82c28681708f39e151af1c1ef7ebeac82d729c01ac")
+sha256sums=("984d28ab3a112be207d6339da19113d1117e56731ed413d0e202e6fd1391a6ae")
package_dxvk-win64-bin () {
arch=('x86_64')
@@ -33,8 +33,7 @@ package_dxvk-bin () {
mkdir -p $pkgdir/usr/share/dxvk
tar -xf dxvk-"$pkgver".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1 dxvk-"$pkgver"/
mkdir -p $pkgdir/usr/bin
- echo "#!/bin/sh" > "$pkgdir/usr/bin/setup_dxvk"
- echo '/usr/share/dxvk/setup_dxvk.sh $1 --symlink --without-dxgi' >> "$pkgdir/usr/bin/setup_dxvk"
+ ln -s /usr/share/dxvk/setup_dxvk.sh "$pkgdir/usr/bin/setup_dxvk"
chmod +x "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
chmod +x "$pkgdir/usr/bin/setup_dxvk"
chown -R root:root "$pkgdir/usr/"