summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2020-01-16 22:47:41 +0100
committerAdrià Cereto-Massagué2020-01-16 22:47:41 +0100
commitaf8ffaa2d196885035b515d2bbfa0b577fa79554 (patch)
tree33ef576012f8289dc650556afa9b45786f74038b
parent2e2ee3af9b44386df740eec18db55aca5979828d (diff)
downloadaur-af8ffaa2d196885035b515d2bbfa0b577fa79554.tar.gz
move around depends to avoid pulling things on build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3475c7436824..1570c5f2c52e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,10 @@
pkgbase = dxvk-bin
pkgdesc = A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/doitsujin/dxvk
arch = x86_64
license = zlib/libpng
- depends = vulkan-icd-loader
- depends = wine>=3.10
- depends = lib32-vulkan-icd-loader
provides = dxvk
provides = d9vk
provides = dxvk=1.5.1
@@ -18,4 +15,7 @@ pkgbase = dxvk-bin
sha256sums = 474ce9995edd47a3bd347a8f3263f35cf8df2676f5b16668bf38efa298d75c01
pkgname = dxvk-bin
+ depends = vulkan-icd-loader
+ depends = wine>=3.10
+ depends = lib32-vulkan-icd-loader
diff --git a/PKGBUILD b/PKGBUILD
index 6ec7154c93df..53e7ab0cf963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,12 @@
pkgbase=dxvk-bin
pkgname=('dxvk-bin')
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)"
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
arch=('x86_64')
provides=("dxvk" "d9vk" "dxvk=$pkgver")
-depends=('vulkan-icd-loader' 'wine>=3.10' 'lib32-vulkan-icd-loader')
conflicts=("dxvk" "d9vk")
options=(!strip)
source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz"
@@ -18,7 +17,7 @@ source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgv
sha256sums=('474ce9995edd47a3bd347a8f3263f35cf8df2676f5b16668bf38efa298d75c01')
package_dxvk-bin () {
- mkdir -p "$pkgdir/usr/share/dxvk"
+ depends=('vulkan-icd-loader' 'wine>=3.10' 'lib32-vulkan-icd-loader')
install -D "dxvk-$pkgver"/x32/* -t "$pkgdir/usr/share/dxvk/x32"
install -D "dxvk-$pkgver"/x64/* -t "$pkgdir/usr/share/dxvk/x64"
install "dxvk-$pkgver"/setup_dxvk.sh -t "$pkgdir/usr/share/dxvk/"