summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2018-08-18 11:17:25 +0200
committerAdrià Cereto-Massagué2018-08-18 11:17:25 +0200
commitd67377be1de0cfbf3047ad573b98354142ed86bf (patch)
tree02aba65720ac01a0fde1c9a07916a040e54de265
parenta4d51aa32c76c4c7b6e2a859ec249753358ee7ee (diff)
downloadaur-d67377be1de0cfbf3047ad573b98354142ed86bf.tar.gz
v0.70
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--setup_dxvk_aur.verb44
3 files changed, 64 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c9ba96fd660..b93dd317176b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-bin
- pkgdesc = A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine (binary files)
- pkgver = 0.65
+ pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (binary files)
+ pkgver = 0.70
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -9,13 +9,16 @@ pkgbase = dxvk-bin
provides = dxvk
conflicts = dxvk-git
options = !strip
- source = https://github.com/doitsujin/dxvk/releases/download/v0.65/dxvk-0.65.tar.gz
- sha256sums = 7b4eb42e693f925d0aff90bae261b20c50428602382ee94a3e3860b2ad1ebad0
+ source = https://github.com/doitsujin/dxvk/releases/download/v0.70/dxvk-0.70.tar.gz
+ source = setup_dxvk_aur.verb
+ sha256sums = 310546d530be494a35cae49b707fef4b073269d811aac25bdf72899ed1df4e9f
+ sha256sums = 1a88e01e02ef9bfd9bf43d8dec4e70b425fb25812f597463ee4145705c82a504
pkgname = dxvk-win64-bin
arch = x86_64
depends = vulkan-icd-loader
depends = wine>=3.10
+ depends = winetricks
provides = dxvk
provides = dxvk64
conflicts = dxvk-git
@@ -28,6 +31,7 @@ pkgname = dxvk-win32-bin
arch = i686
depends = lib32-vulkan-icd-loader
depends = wine>=3.10
+ depends = winetricks
provides = dxvk
provides = dxvk32
conflicts = dxvk-git<0.63-5
diff --git a/PKGBUILD b/PKGBUILD
index 802d40f16012..0cd00fdbe625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,34 @@
pkgbase=dxvk-bin
pkgname=('dxvk-win64-bin' 'dxvk-win32-bin' 'dxvk-bin')
-pkgver=0.65
+pkgver=0.70
pkgrel=1
-pkgdesc="A Vulkan-based compatibility layer for Direct3D 11 which allows running 3D applications on Linux using Wine (binary files)"
+pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (binary files)"
arch=('x86_64' 'i686')
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
provides=("dxvk")
conflicts=("dxvk-git")
options=(!strip)
-source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz")
-sha256sums=("7b4eb42e693f925d0aff90bae261b20c50428602382ee94a3e3860b2ad1ebad0")
+source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz"
+ "setup_dxvk_aur.verb"
+)
+sha256sums=("310546d530be494a35cae49b707fef4b073269d811aac25bdf72899ed1df4e9f"
+ "1a88e01e02ef9bfd9bf43d8dec4e70b425fb25812f597463ee4145705c82a504")
_extract_bin() {
mkdir -p $pkgdir/usr/share/dxvk
tar -xf dxvk-"$pkgver".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1 dxvk-"$pkgver"/x$1
mkdir -p $pkgdir/usr/bin
- ln -s "/usr/share/dxvk/x$1/setup_dxvk.sh" "$pkgdir/usr/bin/setup_dxvk$1"
+ cat setup_dxvk_aur.verb | sed s/"DXVK_ARCH=64"/"DXVK_ARCH=$1"/g > "/usr/share/dxvk/x$1/setup_dxvk_aur.verb"
+ echo "winetricks --force /usr/share/dxvk/x$1/setup_dxvk_aur.verb" > "$pkgdir/usr/bin/setup_dxvk$1"
+ chmod +x "$pkgdir/usr/bin/setup_dxvk$1"
}
package_dxvk-win64-bin () {
arch=('x86_64')
provides=("dxvk" "dxvk64")
- depends=('vulkan-icd-loader' 'wine>=3.10')
+ depends=('vulkan-icd-loader' 'wine>=3.10' 'winetricks')
conflicts=("dxvk-git" "dxvk-bin<0.63-5" "dxvk-win64-git")
replaces=("dxvk-bin<0.63-5")
_extract_bin 64
@@ -32,7 +37,7 @@ package_dxvk-win64-bin () {
package_dxvk-win32-bin () {
arch=('x86_64' 'i686')
provides=("dxvk" "dxvk32")
- depends=('lib32-vulkan-icd-loader' 'wine>=3.10')
+ depends=('lib32-vulkan-icd-loader' 'wine>=3.10' 'winetricks')
conflicts=("dxvk-git<0.63-5" "dxvk-bin<0.63-5" "dxvk-win32-git")
replaces=("dxvk-bin")
_extract_bin 32
diff --git a/setup_dxvk_aur.verb b/setup_dxvk_aur.verb
new file mode 100644
index 000000000000..9fbad9d1b8ed
--- /dev/null
+++ b/setup_dxvk_aur.verb
@@ -0,0 +1,44 @@
+w_metadata setup_dxvk_aur dlls \
+ title="DXVK" \
+ publisher="Philip Rebohle" \
+ year="2018" \
+ media="manual_download" \
+ file1="dxgi.dll" \
+ file2="d3d11.dll" \
+ file3="d3d10.dll" \
+ file4="d3d10_1.dll" \
+ file5="d3d10core.dll" \
+ installed_file1="C:\\windows\\system32\\dxgi.dll" \
+ installed_file2="C:\\windows\\system32\\d3d11.dll" \
+ installed_file3="C:\\windows\\system32\\d3d10.dll" \
+ installed_file4="C:\\windows\\system32\\d3d10_1.dll" \
+ installed_file5="C:\\windows\\system32\\system32/d3d10core.dll" \
+ homepage="https://github.com/doitsujin/dxvk"
+
+DXVK_ROOT_DIR=`dirname "$(readlink -f $1)"`
+DXVK_ARCH=64
+
+load_setup_dxvk_aur()
+{
+ if [ ! -e "$DXVK_ROOT_DIR" ]; then
+ (>&2 echo "$DXVK_ROOT_DIR directory not found.")
+ exit 1
+ fi
+ echo "Setting up DXVK from $DXVK_ROOT_DIR"
+
+ for f in "$file1" "$file2" "$file3" "$file4" "$file5"; do
+ if [ "$DXVK_ARCH" = "32" ]; then
+ w_try ln -fs "$DXVK_ROOT_DIR/$f" "$W_SYSTEM32_DLLS/$f"
+ fi
+ if [ "$DXVK_ARCH" = "64" ]; then
+ w_try ln -fs "$DXVK_ROOT_DIR/$f" "$W_SYSTEM64_DLLS/$f"
+ fi
+ done
+
+ w_override_dlls native \
+ dxgi \
+ d3d11 \
+ d3d10 \
+ d3d10_1 \
+ d3d10core
+}