summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2019-02-26 13:18:48 +0100
committerAdrià Cereto-Massagué2019-02-26 13:18:48 +0100
commite8a9c6290070ea875a21e8bd0d08ca99d53aa57e (patch)
tree22110160869b9e306856ff5332ef1cb627d2479e
parente7a7728622785fc11dab8376996e47c2e68788c7 (diff)
downloadaur-e8a9c6290070ea875a21e8bd0d08ca99d53aa57e.tar.gz
release 1.0, merged packages back
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD46
-rw-r--r--setup_dxvk_aur.verb44
3 files changed, 38 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c49b65461aca..1e400fe74102 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dxvk-bin
- pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (binary files)
- pkgver = 0.96
+ pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
@@ -9,38 +9,31 @@ pkgbase = dxvk-bin
provides = dxvk
conflicts = dxvk-git
options = !strip
- source = https://github.com/doitsujin/dxvk/releases/download/v0.96/dxvk-0.96.tar.gz
- source = setup_dxvk_aur.verb
- sha256sums = 9d054c1e7a4f59825c651b14d3cfbf0d8c724763f485b3d59c89f1d7194b2206
- sha256sums = 1a88e01e02ef9bfd9bf43d8dec4e70b425fb25812f597463ee4145705c82a504
+ source = https://github.com/doitsujin/dxvk/releases/download/v1.0/dxvk-1.0.tar.gz
+ sha256sums = 8c8d26544609532201c10e6f5309bf5e913b5ca5b985932928ef9ab238de6dc2
pkgname = dxvk-win64-bin
+ pkgdesc = Dummy package
arch = x86_64
- depends = vulkan-icd-loader
- depends = wine>=3.10
- depends = winetricks
- provides = dxvk
- provides = dxvk64
- conflicts = dxvk-git
- conflicts = dxvk-bin<0.63-5
- conflicts = dxvk-win64-git
- replaces = dxvk-bin<0.63-5
+ depends = dxvk-bin
pkgname = dxvk-win32-bin
+ pkgdesc = Dummy package
arch = x86_64
arch = i686
- depends = lib32-vulkan-icd-loader
+ depends = dxvk-bin
+
+pkgname = dxvk-bin
+ arch = x86_64
+ depends = vulkan-icd-loader
depends = wine>=3.10
- depends = winetricks
+ depends = lib32-vulkan-icd-loader
provides = dxvk
+ provides = dxvk64
provides = dxvk32
- conflicts = dxvk-git<0.63-5
- conflicts = dxvk-bin<0.63-5
- conflicts = dxvk-win32-git
- replaces = dxvk-bin
-
-pkgname = dxvk-bin
- pkgdesc = Dummy package to smooth the transition to the split packages
- depends = dxvk-win32-bin
- depends = dxvk-win64-bin
+ conflicts = dxvk-git
+ conflicts = dxvk-bin<1.0-1
+ conflicts = dxvk-win64-bin<1.0-1
+ conflicts = dxvk-win32-bin<1.0-1
+ conflicts = dxvk-win64-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c4c9ce88115..e6627c7268d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgbase=dxvk-bin
pkgname=('dxvk-win64-bin' 'dxvk-win32-bin' 'dxvk-bin')
-pkgver=0.96
+pkgver=1.0
pkgrel=1
-pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (binary files)"
+pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)"
arch=('x86_64' 'i686')
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
@@ -12,38 +12,30 @@ provides=("dxvk")
conflicts=("dxvk-git")
options=(!strip)
source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz"
- "setup_dxvk_aur.verb"
)
-sha256sums=("9d054c1e7a4f59825c651b14d3cfbf0d8c724763f485b3d59c89f1d7194b2206"
- "1a88e01e02ef9bfd9bf43d8dec4e70b425fb25812f597463ee4145705c82a504")
-
-_extract_bin() {
- mkdir -p $pkgdir/usr/share/dxvk
- tar -xf dxvk-"$pkgver".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1 dxvk-"$pkgver"/x$1
- mkdir -p $pkgdir/usr/bin
- cat setup_dxvk_aur.verb | sed s/"DXVK_ARCH=64"/"DXVK_ARCH=$1"/g > "$pkgdir/usr/share/dxvk/x$1/setup_dxvk_aur.verb"
- echo "#!/bin/sh" > "$pkgdir/usr/bin/setup_dxvk$1"
- echo "winetricks --force /usr/share/dxvk/x$1/setup_dxvk_aur.verb" >> "$pkgdir/usr/bin/setup_dxvk$1"
- chmod +x "$pkgdir/usr/bin/setup_dxvk$1"
-}
+sha256sums=("8c8d26544609532201c10e6f5309bf5e913b5ca5b985932928ef9ab238de6dc2")
package_dxvk-win64-bin () {
arch=('x86_64')
- provides=("dxvk" "dxvk64")
- depends=('vulkan-icd-loader' 'wine>=3.10' 'winetricks')
- conflicts=("dxvk-git" "dxvk-bin<0.63-5" "dxvk-win64-git")
- replaces=("dxvk-bin<0.63-5")
- _extract_bin 64
+ depends=('dxvk-bin')
+ pkgdesc="Dummy package"
}
package_dxvk-win32-bin () {
arch=('x86_64' 'i686')
- provides=("dxvk" "dxvk32")
- depends=('lib32-vulkan-icd-loader' 'wine>=3.10' 'winetricks')
- conflicts=("dxvk-git<0.63-5" "dxvk-bin<0.63-5" "dxvk-win32-git")
- replaces=("dxvk-bin")
- _extract_bin 32
+ depends=('dxvk-bin')
+ pkgdesc="Dummy package"
}
package_dxvk-bin () {
- pkgdesc="Dummy package to smooth the transition to the split packages"
- depends=("dxvk-win32-bin" "dxvk-win64-bin")
+ arch=('x86_64')
+ provides=("dxvk" "dxvk64" "dxvk32")
+ depends=('vulkan-icd-loader' 'wine>=3.10' 'lib32-vulkan-icd-loader')
+ conflicts=("dxvk-git" "dxvk-bin<1.0-1" "dxvk-win64-bin<1.0-1" "dxvk-win32-bin<1.0-1" "dxvk-win64-git")
+ mkdir -p $pkgdir/usr/share/dxvk
+ tar -xf dxvk-"$pkgver".tar.gz -C "$pkgdir/usr/share/dxvk" --strip-components=1 dxvk-"$pkgver"/
+ mkdir -p $pkgdir/usr/bin
+ echo "#!/bin/sh" > "$pkgdir/usr/bin/setup_dxvk"
+ echo '/usr/share/dxvk/setup_dxvk.sh $1 --symlink --without-dxgi' >> "$pkgdir/usr/bin/setup_dxvk"
+ chmod +x "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
+ chmod +x "$pkgdir/usr/bin/setup_dxvk"
+ chown -R root:root "$pkgdir/usr/"
}
diff --git a/setup_dxvk_aur.verb b/setup_dxvk_aur.verb
deleted file mode 100644
index 9fbad9d1b8ed..000000000000
--- a/setup_dxvk_aur.verb
+++ /dev/null
@@ -1,44 +0,0 @@
-w_metadata setup_dxvk_aur dlls \
- title="DXVK" \
- publisher="Philip Rebohle" \
- year="2018" \
- media="manual_download" \
- file1="dxgi.dll" \
- file2="d3d11.dll" \
- file3="d3d10.dll" \
- file4="d3d10_1.dll" \
- file5="d3d10core.dll" \
- installed_file1="C:\\windows\\system32\\dxgi.dll" \
- installed_file2="C:\\windows\\system32\\d3d11.dll" \
- installed_file3="C:\\windows\\system32\\d3d10.dll" \
- installed_file4="C:\\windows\\system32\\d3d10_1.dll" \
- installed_file5="C:\\windows\\system32\\system32/d3d10core.dll" \
- homepage="https://github.com/doitsujin/dxvk"
-
-DXVK_ROOT_DIR=`dirname "$(readlink -f $1)"`
-DXVK_ARCH=64
-
-load_setup_dxvk_aur()
-{
- if [ ! -e "$DXVK_ROOT_DIR" ]; then
- (>&2 echo "$DXVK_ROOT_DIR directory not found.")
- exit 1
- fi
- echo "Setting up DXVK from $DXVK_ROOT_DIR"
-
- for f in "$file1" "$file2" "$file3" "$file4" "$file5"; do
- if [ "$DXVK_ARCH" = "32" ]; then
- w_try ln -fs "$DXVK_ROOT_DIR/$f" "$W_SYSTEM32_DLLS/$f"
- fi
- if [ "$DXVK_ARCH" = "64" ]; then
- w_try ln -fs "$DXVK_ROOT_DIR/$f" "$W_SYSTEM64_DLLS/$f"
- fi
- done
-
- w_override_dlls native \
- dxgi \
- d3d11 \
- d3d10 \
- d3d10_1 \
- d3d10core
-}