summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2022-08-23 22:16:54 +0200
committerAdrià Cereto-Massagué2022-08-23 22:16:54 +0200
commit101043b0be0c6d87e6d3de24940ada05cf643bdd (patch)
treeee9770f2f0678f2da4d46707f7e5977061500fac
parente83bfdd7c44a11df6f054489e3396387927a3492 (diff)
downloadaur-101043b0be0c6d87e6d3de24940ada05cf643bdd.tar.gz
added submodules
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 29 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb3d66acbbbf..f4c466339768 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dxvk-git
pkgdesc = A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)
- pkgver = 1.5.r3.ga265af74
- pkgrel = 2
+ pkgver = 1.10.1.r695.g87b1f9fa
+ pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
license = zlib/libpng
@@ -16,7 +16,7 @@ pkgbase = dxvk-git
depends = lib32-vulkan-icd-loader
provides = dxvk
provides = d9vk
- provides = dxvk=1.5.r3.ga265af74
+ provides = dxvk=1.10.1.r695.g87b1f9fa
conflicts = d9vk-mingw-git
conflicts = d9vk-bin
conflicts = d9vk-winelib-git
@@ -31,9 +31,14 @@ pkgbase = dxvk-git
options = !buildflags
options = staticlibs
source = git+https://github.com/doitsujin/dxvk.git
+ source = https://github.com/Joshua-Ashton/mingw-directx-headers
+ source = https://github.com/KhronosGroup/Vulkan-Headers
+ source = https://github.com/KhronosGroup/SPIRV-Headers.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = dxvk-mingw-git
arch = x86_64
conflicts = dxvk-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 9cebf8339052..aad0630268cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=dxvk-git
pkgname=('dxvk-mingw-git')
-pkgver=1.5.r3.ga265af74
-pkgrel=2
+pkgver=1.10.1.r695.g87b1f9fa
+pkgrel=1
pkgdesc="A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)"
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
@@ -13,8 +13,15 @@ provides=("dxvk" "d9vk" "dxvk=$pkgver")
makedepends=('ninja' 'meson>=0.43' 'glslang' 'mingw-w64-gcc' 'git' 'wine')
conflicts=('d9vk-mingw-git' 'd9vk-bin' 'd9vk-winelib-git' "dxvk-bin" "dxvk-git" "dxvk-wine32-git" "dxvk-wine64-git" "dxvk-win32-git" "dxvk-win64-git" "dxvk-winelib-git")
options=(!strip !buildflags staticlibs)
-source=("git+https://github.com/doitsujin/dxvk.git")
-sha256sums=("SKIP")
+source=("git+https://github.com/doitsujin/dxvk.git"
+"https://github.com/Joshua-Ashton/mingw-directx-headers"
+"https://github.com/KhronosGroup/Vulkan-Headers"
+"https://github.com/KhronosGroup/SPIRV-Headers.git"
+)
+sha256sums=("SKIP"
+"SKIP"
+"SKIP"
+"SKIP")
pkgver() {
@@ -22,6 +29,15 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
}
+prepare() {
+ cd dxvk
+ git submodule init
+ git config submodule.mingw-directx-headers.url "$srcdir/include/native/directx"
+ git config submodule.Vulkan-Headers.url "$srcdir/include/vulkan"
+ git config submodule.SPIRV-Headers.git.url "$srcdir/include/spirv"
+ git submodule update
+}
+
build() {
meson dxvk "build/x64" \
--cross-file dxvk/build-win64.txt \