summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2019-05-04 21:24:30 +0200
committerAdrià Cereto-Massagué2019-05-04 21:24:30 +0200
commit4df0bcb974decec0ecdb64f4a645c2d24d7cfb05 (patch)
tree4b6509aaabeb4e7b6da1329c38d164b1488d02f1
parent58ea7cfbaa02f3c2e89d753bc418735074229636 (diff)
downloadaur-4df0bcb974decec0ecdb64f4a645c2d24d7cfb05.tar.gz
slay dummies
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba782351fc65..c145493dbea1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = dxvk-git
pkgdesc = A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)
- pkgver = 1.0.r1.g71186859
+ pkgver = 1.1.1.r0.g37f9a7ff
pkgrel = 1
url = https://github.com/doitsujin/dxvk
arch = x86_64
- arch = i686
license = zlib/libpng
makedepends = ninja
makedepends = meson>=0.43
@@ -15,20 +14,19 @@ pkgbase = dxvk-git
depends = vulkan-icd-loader
depends = wine>=4.0rc1
depends = lib32-vulkan-icd-loader
+ conflicts = dxvk-bin
+ conflicts = dxvk-git
+ conflicts = dxvk-wine32-git
+ conflicts = dxvk-wine64-git
+ conflicts = dxvk-win32-git
+ conflicts = dxvk-win64-git
+ conflicts = dxvk-winelib-git
options = !strip
options = !buildflags
options = staticlibs
source = git+https://github.com/doitsujin/dxvk.git
sha256sums = SKIP
-pkgname = dxvk-win64-git
- pkgdesc = Dummy package
- depends = dxvk-mingw-git
-
-pkgname = dxvk-win32-git
- pkgdesc = Dummy package
- depends = dxvk-mingw-git
-
pkgname = dxvk-mingw-git
arch = x86_64
conflicts = dxvk-bin
diff --git a/PKGBUILD b/PKGBUILD
index 908a64d46e7f..c7057a01fd7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Adrià Cereto i Massagué <ssorgatem at gmail.com>
pkgbase=dxvk-git
-pkgname=('dxvk-win64-git' 'dxvk-win32-git' 'dxvk-mingw-git')
-pkgver=1.0.r1.g71186859
+pkgname=('dxvk-mingw-git')
+pkgver=1.1.1.r0.g37f9a7ff
pkgrel=1
pkgdesc="A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)"
-arch=('x86_64' 'i686')
+arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
license=('zlib/libpng')
depends=('vulkan-icd-loader' 'wine>=4.0rc1' 'lib32-vulkan-icd-loader')
makedepends=('ninja' 'meson>=0.43' 'glslang' 'mingw-w64-gcc' 'git' 'wine')
+conflicts=("dxvk-bin" "dxvk-git" "dxvk-wine32-git" "dxvk-wine64-git" "dxvk-win32-git" "dxvk-win64-git" "dxvk-winelib-git")
options=(!strip !buildflags staticlibs)
source=("git+https://github.com/doitsujin/dxvk.git")
sha256sums=("SKIP")
@@ -40,15 +41,6 @@ build() {
ninja -C "build/x32"
}
-package_dxvk-win64-git() {
- pkgdesc="Dummy package"
- depends=("dxvk-mingw-git")
-}
-package_dxvk-win32-git() {
- pkgdesc="Dummy package"
- depends=("dxvk-mingw-git")
-}
-
package_dxvk-mingw-git() {
arch=('x86_64')
conflicts=("dxvk-bin")
@@ -56,9 +48,5 @@ package_dxvk-mingw-git() {
DESTDIR="$pkgdir" ninja -C "build/x64" install
install -Dm 644 dxvk/setup_dxvk.sh "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
mkdir -p "$pkgdir/usr/bin"
- echo "#!/bin/sh" > "$pkgdir/usr/bin/setup_dxvk"
- echo '/usr/share/dxvk/setup_dxvk.sh $1 --symlink --without-dxgi' >> "$pkgdir/usr/bin/setup_dxvk"
- chmod +x "$pkgdir/usr/share/dxvk/setup_dxvk.sh"
- chmod +x "$pkgdir/usr/bin/setup_dxvk"
- chown -R root:root "$pkgdir/usr/"
+ ln -s /usr/share/dxvk/setup_dxvk.sh "$pkgdir/usr/bin/setup_dxvk"
}